# Table of Contents

About This Manual .................................................. xv
Audience ............................................................... xv
Customer Support .................................................... xviii

1. Introducing AvanWaves
   Features .............................................................. 1-2
   Design Flow .......................................................... 1-3
   Input Files ............................................................ 1-4
   Output Files .......................................................... 1-4
   Directory Structure ................................................ 1-5

2. Getting Started
   Starting AvanWaves ............................................... 2-2
   Using AvanWaves ................................................... 2-3
       Opening the Design ............................................. 2-3
       Selecting the Analysis Files ................................ 2-4
       Displaying a Waveform ....................................... 2-5
       Adding a New Panel .......................................... 2-6
Displaying a Second Waveform ........................................... 2-7
Summary ................................................................. 2-8

3. Working With Designs

Open Design Window ......................................................... 3-2
Selecting Menus ............................................................... 3-4
  History Menu ............................................................. 3-4
  Special Menu ............................................................. 3-4
  View ................................................................. 3-4
  Filter Menu ............................................................. 3-5
  Buttons ............................................................... 3-6
Accepted File Types ........................................................ 3-6
Close Design Window ......................................................... 3-7
Current Design Window ...................................................... 3-8
Exiting the Design ........................................................... 3-9

4. AvanWaves User Interface

Invoking AvanWaves ......................................................... 4-2
Using the Mouse ........................................................... 4-3
Tools ................................................................. 4-4
Results Browser ........................................................... 4-4
  Current Design Field and Scroll List .......................... 4-5
Hierarchy Browser Scroll List .......................................... 4-5
Types Scroll List ......................................................... 4-6
Curves Scroll List ......................................................... 4-7
Current X-Axis Selector ................................................... 4-7
Filter Selector ........................................................... 4-8
Measure Preferences .................................................... 4-31
The Select Preference Window ...................................... 4-31
Set General Preferences Dialog ...................................... 4-33
Set Analysis Preferences Window .................................... 4-34
  Curve .................................................................... 4-35
  Color .................................................................... 4-35
  Continuity ............................................................... 4-35
  Line Style ............................................................... 4-36
  Symbol .................................................................. 4-36
  Frequency ............................................................. 4-36
  Setting your Preference .............................................. 4-36
Symbol Chooser ............................................................. 4-37
Line Style Chooser .......................................................... 4-38
Keyboard Shortcuts and Hotkeys ....................................... 4-39

5. Viewing Waveforms

  Changing Views in a Panel ............................................. 5-2
    Full .................................................................... 5-2
    Zoom In X ................................................................ 5-2
    Zoom Out X .......................................................... 5-3
    Zoom In Y ................................................................ 5-3
    Zoom Out Y .......................................................... 5-4
    Zoom In X/Y ........................................................... 5-5
    Zoom Out X/Y ......................................................... 5-5
    Last Zoom .............................................................. 5-6
    Pan X .................................................................. 5-6
    Pan Y .................................................................. 5-6
    Pan X/Y ............................................................... 5-7
    Stacked/Overlay ...................................................... 5-7
Performing Measurements .............................................. 5-8
Measure ........................................................................... 5-9
Anchor Cursor ................................................................. 5-9
Measure Label Dialog ....................................................... 5-12

6. Creating Macros and Expressions

Expression Builder ........................................................... 6-2
Functions ......................................................................... 6-3
Operators ......................................................................... 6-4
Using Curves in Expressions ............................................. 6-4
Selecting and Editing Expressions. ................................. 6-5
Using Expressions ........................................................... 6-6
Deleting Expressions ....................................................... 6-7

Macro Builder ................................................................. 6-8
Creating and Using Macros .............................................. 6-9
Displaying a Macro ......................................................... 6-10
Editing a Macro ................................................................ 6-10
Loading a Macro .......................................................... 6-11
Saving a Macro ............................................................... 6-12
Deleting a Macro .......................................................... 6-13

7. Using Configurations

Configuration Files .......................................................... 7-2
Saving a Configuration ................................................... 7-2
Opening a Configuration ................................................ 7-3
Deleting a Configuration .............................................. 7-4

8. Setting Preferences

Select Preferences Window ............................................ 8-2
Setting Analysis Preferences ........................................... 8-3
  Setting Waveform Color ............................................ 8-3
  Setting Continuity Display ........................................ 8-4
  Setting Line Style .................................................. 8-4
  Setting Symbol Type ............................................... 8-4
  Setting Symbol Frequency ........................................ 8-5
Setting General Preferences .......................................... 8-5
  Setting Font ......................................................... 8-5
  Setting Background and Foreground Colors ..................... 8-6

9. Run Manager

Invoking the Run Manager ............................................ 9-2
Running HSPICE ....................................................... 9-4
Editing the HSPICE Source File .................................... 9-4
Viewing the Listing File ............................................. 9-5
Run Manager Preferences ............................................. 9-6

10. Running the Tutorial

Invoking AvanWaves .................................................. 10-2
Transient and FFT Analysis .......................................... 10-3
  Opening the Design ............................................... 10-3
  Selecting the Analysis File ..................................... 10-3
Sweep Filtering .......................................................... 10-6
Zoom In X Feature ...................................................... 10-8
Measures ................................................................. 10-8
FFT Analysis ............................................................. 10-9
Changing Display Parameters ................................. 10-11
Transient Analysis Summary .................................. 10-12

AC Analysis ............................................................. 10-12
Displaying Waveforms ............................................ 10-13
Changing the Scale of the Display ......................... 10-14
Setting the Zoom Factor ........................................ 10-15
Measuring Unity Gain Frequency and Phase Margin .... 10-17
Saving the Configuration ........................................ 10-18
AC Analysis Summary .............................................. 10-18

11. Accessing Online Help

Help Page ............................................................... 11-3
Section Menu .......................................................... 11-4
Topic Selection Arrows ........................................... 11-5
Bookmarks .............................................................. 11-5

Help-DocSet Browser .............................................. 11-6
Using the Entries List to Get Help .......................... 11-7
Using Search to Get Help ........................................ 11-8
Appendix A. Command Summary

Appendix B. Operators and Functions
  Operators ................................................................. B-2
  Predefined Functions ................................................. B-3
  FFT Parameters ....................................................... B-4

Appendix C. Terms and Naming Conventions

Index ................................................................. IN-1
Preface

This preface includes the following sections:

- What's New in This Release
- About This Manual
- Customer Support
What’s New in This Release

This section describes the new features, enhancements, and changes included in Avanwaves User Guide version 2005.03. Unless otherwise noted, you can find additional information about these changes later in this book.

New Features

See the HSPICE and AvanWaves Release Notes for information about new features and last-minute changes.

Known Limitations and Resolved D/Es

Information about known problems and limitations, as well as about resolved Synopsys Technical Action Requests (STARs), is available in the HSPICE and AvanWaves Release Notes in SolvNet.

To see the HSPICE and AvanWaves Release Notes:

2. If prompted, enter your user name and password. (If you do not have a Synopsys user name and password, click New Synopsys User Registration.)
About This Manual

The *Avanwaves User Guide* describes the AvanWaves tool that you can use to display waveforms generated when you simulated your circuit designs in HSPICE or Star-SimXT.

Audience

This manual is for circuit designers and engineers who use Synopsys circuit simulation tools, including the HSPICE and Star-Sim product families.
Conventions

This manual uses the following conventions.

Commands

**SYNTAX:**

`command_name [argument(s)]`

*argument types:* `keyword | value | tag=value | tag=keyword`

<table>
<thead>
<tr>
<th>Command Argument</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>keyword</td>
<td>Keywords are identifiers that must be used as they appear. They are shown in base font.</td>
</tr>
<tr>
<td>value</td>
<td>Values are user-determined. They are shown in italic text to distinguish them from commands and keywords.</td>
</tr>
<tr>
<td>tag=value keyword</td>
<td>Tags can be followed by either a value or a keyword. Tags and keywords are in the base font. Argument values are in italics to distinguish them from commands, keywords, and tags.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>`</td>
<td>`</td>
</tr>
<tr>
<td><code>...</code></td>
<td>An ellipsis ( ... ) indicates that more than one argument can be specified. Ellipses are used only for multiple arguments with tags.</td>
</tr>
<tr>
<td><code>[ ]</code></td>
<td>Open and closed square brackets indicate that the enclosed argument is optional.</td>
</tr>
<tr>
<td><code>( )</code></td>
<td>Open and closed parenthesis indicate that there is a choice between the enclosed arguments (two or more). These are used only when a command has several groups of argument choices; multiple pipe symbols (</td>
</tr>
</tbody>
</table>
Command Names

Command Names are shown in the same font as the surrounding text, but in bold, as shown in the following example.

EXAMPLE 1:

Select the **Window > Set Zoom** option to display the **Zoom Selected Panels** dialog window.

File Names

File names are shown in the same font as the surrounding text, but in italics.

EXAMPLE 2:

This is an example of a *file_name.out* being shown in text.

Examples

Examples are shown in a courier font as they might appear on your screen.

EXAMPLE 3:

```
awaves [[-i][-plot][-d] <path><design_name> [-c <config_name>]]
[ -laf ( windows|openlook|motif ) ]
```
Customer Support

For customer support, use the SolvNet online customer support system, or contact the Synopsys Technical Support Center.

Accessing SolvNet

SolvNet includes an electronic knowledge base of technical articles and answers to frequently asked questions about Synopsys tools. SolvNet also gives you access to a wide range of Synopsys online services, including software downloads, documentation on the Web, and “Enter a Call With the Support Center.”

To access SolvNet,

2. If prompted, enter your user name and password. (If you do not have a Synopsys user name and password, click New Synopsys User Registration.)

If you need help using SolvNet, click SolvNet Help in the column on the left side of the SolvNet Web page.

Contacting the Synopsys Technical Support Center

If you have problems, questions, or suggestions, you can contact the Synopsys Technical Support Center in the following ways:

- To open a call to your local support center from the Web, go to http://solvnet.synopsys.com (Synopsys user name and password required), then click “Enter a Call With the Support Center.”
- Send an e-mail message to support_center@synopsys.com.
Telephone your local support center.

- Call (800) 245-8005 from within the continental United States.
- Call (650) 584-4200 from Canada.
- Find other local support center telephone numbers at http://www.synopsys.com/support/support_ctr.
Preface

xx
Introducing AvanWaves

This chapter introduces you to the AvanWaves product, and describes the features available and the input files utilized.

AvanWaves is available on Unix and PC platforms only.
Features

AvanWaves provides a convenient graphical interface to display, analyze, and print the results of HSPICE simulations. This version of AvanWaves enables you to

- Load all files associated with a particular design in one step
- Open multiple designs simultaneously
- Update an existing design with information obtained from a new simulation run
- Superimpose results with two different data types within one graph, using up to two different Y-axes
- Build algebraic expressions and macros to modify and combine simulation results for display
- Graph (without limitations) simulation results or for displaying panels
- Interactively measure and label data on waveforms
- Save and restore all aspects of a particular design analysis as a configuration
- Look at individual parametric variations using the Sweep Filter
- Produce hard copy prints of the design analysis and results display
- Access online Help
- Run HSPICE within the waveform analysis section
Design Flow

Figure 1-1 shows the design flow diagram for AvanWaves.

Figure 1-1  AvanWaves Design Flow Diagram

Open Design

Select Analysis

Review Simulation Data Available

Open Configuration File

Graph Results

Build Expressions and Macros

Measure

Print

Save Configuration File
Input Files

HSPICE run files and configuration files saved during a AvanWaves session are used as input to AvanWaves. The configuration file is located in a directory having the same name as your current design with a .sav extension. The configuration file is located in the `<design_name>.sav` directory and has a .cfg extension.

Table 1-1 lists the HSPICE run files used as input to AvanWaves.

### Table 1-1 Files used as input to AvanWaves

<table>
<thead>
<tr>
<th>Design File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;design&gt;.sp</code></td>
<td>HSPICE input netlist</td>
</tr>
<tr>
<td><code>&lt;design&gt;.st#</code></td>
<td>Status file</td>
</tr>
<tr>
<td><code>&lt;design&gt;.pa#</code></td>
<td>Subcircuit cross-listing file</td>
</tr>
<tr>
<td><code>&lt;design&gt;.lis</code></td>
<td>Output listing file</td>
</tr>
<tr>
<td><code>&lt;design&gt;.tr#</code></td>
<td>Transient analysis results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.mt#</code></td>
<td>Transient measure data file. An associated <code>&lt;design&gt;.tr#</code> file must exist for this file to be current</td>
</tr>
<tr>
<td><code>&lt;design&gt;.ac#</code></td>
<td>AC analysis results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.ma#</code></td>
<td>AC analysis measurement results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.sw#</code></td>
<td>DC analysis results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.ms#</code></td>
<td>DC analysis measurement results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.xp#</code></td>
<td>Transient analysis results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.cm#</code></td>
<td>Transient analysis results</td>
</tr>
<tr>
<td><code>&lt;design&gt;.wv#</code></td>
<td>Transient analysis results</td>
</tr>
</tbody>
</table>

Output Files

AvanWaves can save all design data, analyses and waveforms created to display the data in a “configuration”. You can save each configuration to a configuration file with a unique name, in the form `<config_name>.cfg`, in the `<design>.sav` directory
Introducing AvanWaves: Directory Structure

Figure 1-2 shows the directory structure for AvanWaves.

Figure 1-2  Directory Structure
Introducing AvanWaves: Directory Structure

1-6
2

Getting Started

This chapter provides some simple procedures to help you understand and use the basic functions of AvanWaves.
Starting AvanWaves

1. Set up your demo environment Change directory to

   $installdir/demo/awaves.

2. Load AvanWaves.

   You can run AvanWaves under different window manager environments:

   - Using Motif

     Motif is the default environment for AvanWaves. To start AvanWaves on the command line from any directory, type:

     awaves

     For backward compatibility, you can also type mwaves to start AvanWaves.

   - Using other window manager environments

     Start AvanWaves on the command line from any directory, specifying the window manager that you are using, as follows:

     awaves -laf [windows|openlook|motif]

     The AvanWaves application is loaded and the Results Display window is displayed under the selected window manager.

     Note: This user guide describes AvanWaves behavior under the Motif window manager (default). You will see some differences in user interface appearance and functionality for the other window managers.

     Invoking AvanWaves on page 4-2 lists all invocation options.
Using AvanWaves

The following example demonstrates how to use AvanWaves to analyze the results of an HSPICE DC analysis for a MOS device, displaying a family of I vs. V curves. The example uses the design mosiv.sp, in the $installdir/demo/awaves/tutorial/dc directory.

Opening the Design

To open the mosiv.sp design:

1. In the Results Display window, select the Design > Open command, using the right mouse button.

   The Open Design window appears.

2. In the Open text area, enter the following design file path name:

   $installdir/awaves/tutorial/dc/mosiv.sp

3. Click on OK with the left mouse button.

   The Results Browser opens as shown in Figure 2-1, listing the analysis files for the design.
Selecting the Analysis Files

The analysis is set up by selecting an analysis file and an analysis type, as follows:

1. In the Results Browser, select the DC analysis, sw0.
   This is the file to be used in the analysis.

2. In the Types scroll box, select the analysis data type Currents.
   A list of all curves associated with the selected data type is displayed in the Curves scroll box.
Displaying a Waveform

Waveforms display in the Results Display window. One panel opens by default when you open this window. To display the waveform associated with the $i(mvg2)$ curve:

- In the Curves section of the Results Browser, select the curve $i(mvg2)$ with the left mouse button. Use the middle mouse button to drag and drop it into the panel in the Results Display window.

  The selected waveform displays, as shown in Figure 2-2.

- As an alternative way of displaying the waveform:
  1. Click on the panel where you want the curve to display.
  2. In the Results Browser, double-click on the name of the curve.

  The selected curve waveform displays in the selected panel.

Figure 2-2  $i(mvg2)$ curve Displayed in the Results Display window
Adding a New Panel

You can open several panels in the Results Display window at the same time, for comparisons. To add a new panel to the Results Display window, select **Add** from the Panels pulldown menu.

A new panel is added to the Display area, as shown in Figure 2-3. Panels are automatically named as they are added.

**Figure 2-3  Results Display Window with Addition of New Panel**

![Results Display Window with Addition of New Panel](image)

The number of panels in the Results Display Window is limited only by the size of the Results Display window. If the window is too small, this message displays when you select **Add** from the Panels menu.

> Not enough room to display new panel. Added as hidden panel.

The panel is added to the Panel List within the Panels pulldown menu as a hidden panel. To display the panel, increase the size of the Results Display window, then double-click on the hidden panel.
Displaying a Second Waveform

To display a second waveform in the new panel:

1. Click the L mouse button in the new panel to select it.
2. In the Results Browser, select the DC analysis sw1.
3. In the Types section, select the analysis data type **Currents**.
4. In the Curves section of the Results Browser, select i(mvg2) using the L mouse button, then double click the L mouse button to produce the curve in the selected display panel, as shown in Figure 2-4. Alternatively, you can drag the selected curve into the panel in the Results Display window using:
   - **L mouse button** (OpenLook desktop)
   - **middle mouse button** (Motif desktop)

To delete a waveform in a panel, select the waveform in the wave list and press **Del**.

*Figure 2-4  Two curves displayed in two panels*
Summary

The example used throughout this chapter described how to open a design, select analysis files to evaluate, add panels, then display waveforms. These are the basic functions provided by AvanWaves.
Working With Designs

A design is the collective information that describes your circuit, such as the netlist, the analysis files, and the simulation graph data files. This chapter describes the operations you can perform in AvanWaves using the Design menu. This includes opening, closing, and saving designs.
Open Design Window

The Open Design window shown in Figure 3-1 allows you to open one or more designs in AvanWaves. The window has a menu bar with four menus, a pop-up directory selector button, lists of directories and files, scrolling buttons for the lists, and an Open field.

To select a directory, click and hold down the pop-up directory selector button, and slide the selector to the directory name. The left-hand list shows the contents of the directory you select. If the item selected in the left-hand list is a directory, the contents of that directory are shown in the right-hand list.

Figure 3-1  Open Design Window
To open a design:

1. From the results display window, select **Design > Open**.

2. In the Open Design window directory selector pop-up menu, select the directory that contains the design you want to open. This is the *run* directory.

3. If the design file is in a subdirectory of the *run* directory, select the subdirectory in the left-hand list area in the **Open Design** window.

4. In the right-hand list area, select the simulation file you want to open.

5. On opening the design, AvanWaves collects all of the files associated with this design (the HSPICE input and output files and the other associated files having the same design root name) from the path specified.

You can navigate through the directory structure in the following ways:

- Enter a path and design name into the Open field in the dialog box.
- Double click on a directory to display its contents.
  - Use the < button to select the parent directory or use the > button to select a subdirectory.
  - In the History menu, select designs that you previously visited.
- Select a path from the pop-up menu. This menu always contains the name of your current directory.

To open the design, double click on the design name or select the design from the file list displayed, and then click **OK or Apply**.
Selecting Menus

The following selections can be made in the Open Design window:

History Menu

Select the History menu to get a list of the paths to designs previously visited in this AvanWaves session. The maximum number of paths that can be displayed is five. The first item in the list is the path to the current design. Selecting one of the paths from this list opens the selected design and close the currently-active design. The History list is updated whenever you use the Special > Mark or Special > Unmark command.

Special Menu

Select the Special menu to:

- Return to your home directory
- Mark a directory location for permanent entry in the History list
- Remove the current directory location from the marked list

View

Select the View option to change the order in which file names are displayed in the file list. You can display files:

- **by Name** — Lists the files by name in alphabetical order
- **by Date Modified** — Lists the files according to the last date they were modified
- **by Date Created** — Lists the files by the date created
Filter Menu

Select the Filter menu to limit the number of files selected by selecting the types of files displayed in the file list. There is a file extensions submenu that lets you specify the default extension to the HSPICE input netlist (defaults to *.sp). The Filter menu lists six types of files, with a button for each type. When a button for a file type is clicked, that type of file is selected for display. A button that is not depressed means that type of file is not selected.

You can select any combination of file types.

*Table 3-1 File Types in the Filter Menu*

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Display input files only</td>
</tr>
<tr>
<td>Listing</td>
<td>Display listing files only</td>
</tr>
<tr>
<td>Raw Output</td>
<td>Display raw data files only (HSPICE graph data files: *.tr0, *.ac0, *.sw0, *.cw, *.wv, *.xp)</td>
</tr>
<tr>
<td>Measures</td>
<td>Display measure data files only (*mt0, *.ma0)</td>
</tr>
<tr>
<td>All Files</td>
<td>Display all the files in the current directory</td>
</tr>
<tr>
<td>Options</td>
<td>Display the filename extensions for input and history files</td>
</tr>
</tbody>
</table>
Buttons

Table 3-2 Open Design Window Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click OK after selecting the design from the list to open the design and close the Open Design window.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click Apply after selecting the design from the list to open the design without closing the Open Design window. To close the Open Design window, you must click Cancel.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operation and close the Open Design window.</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to get the AvanWaves on-line Help on the current dialog box.</td>
</tr>
</tbody>
</table>

Accepted File Types

Design files are HSPICE simulation input or output files that are used as input to AvanWaves. You can open a design file by specifying the path to the design files, then selecting the file type on the Filter menu. AvanWaves accepts these file types:

Table 3-3 File Types in AvanWaves

<table>
<thead>
<tr>
<th>Design File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;design&gt;.sp</td>
<td>HSPICE input netlist</td>
</tr>
<tr>
<td>&lt;design&gt;.st0</td>
<td>status file</td>
</tr>
<tr>
<td>&lt;design&gt;.lis</td>
<td>output listing file</td>
</tr>
<tr>
<td>&lt;design&gt;.tr#</td>
<td>raw transient simulation output data</td>
</tr>
<tr>
<td>&lt;design&gt;.sw#</td>
<td>DC analysis graph data file</td>
</tr>
<tr>
<td>&lt;design&gt;.ac#</td>
<td>AC analysis graph data file</td>
</tr>
<tr>
<td>&lt;design&gt;.mt#</td>
<td>transient measure data file. An associated design.tr# file must exist for this file to be current.</td>
</tr>
<tr>
<td>&lt;design&gt;.ms#</td>
<td>DC measure data file. An associated design.sw# file must exist for this file to be current.</td>
</tr>
</tbody>
</table>
The Close Design window lists all designs you have opened in your current AvanWaves session. To close a design:

1. From the Results Display window, Select Design > Close. The Close Design window appears, as shown in Figure 3-2.

2. Select the design that you want to close, then click OK or Apply. Double clicking the design has the same effect as clicking Apply.

Figure 3-2 Close Design

Table 3-4 Close Design Windows Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>After selecting the design from the list, click OK to close the design. This removes the design from the current session and closes the Close Design window.</td>
</tr>
<tr>
<td>Apply</td>
<td>After selecting the design from the list, click Apply to close the design. This removes the design from the current session. You must click Cancel to close the Close Design window.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operation and close the Close Design window.</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to get the AvanWaves on-line Help on the current dialog box.</td>
</tr>
</tbody>
</table>
Current Design Window

The Current Design window lists all open designs in your current AvanWaves session. It provides the full path to the design. You can select a new current design from the designs list. Setting the current design refreshes the Results Browser with current design data.

Designs are represented by design numbers $D_0$ through $D_n$. The design number identifies your design and is referenced throughout the application. It is used to identify displayed waveforms.

To select a new current design:

1. Select Design > Current from the Results display window. The Current Design window appears, as shown in Figure 3-3.
2. Select a design.
3. Click OK or Apply.

**Figure 3-3  Current Design**

![Current Design Window](image)

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click OK after viewing the current design or after selecting a new current design. The new design is automatically loaded into AvanWaves. Double clicking on the design has the same effect as clicking OK.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click Apply to apply any changes you made. If you selected a new design, the new design is brought in as your current design. You must click Cancel to close the Close Design window.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operation and close the Current Design window.</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to get the AvanWaves on-line Help on the current dialog box.</td>
</tr>
</tbody>
</table>

Table 3-5  Current Design Window Buttons
Exiting the Design

To close the design and quit AvanWaves, do the following:

1. Select Design > Exit in the Results Display window.

   The Exit AvanWaves dialog box is displayed. You are given the option of saving your current design configuration before quitting. Refer to Chapter 7, “Using Configurations” for information about saving and restoring AvanWaves configurations.

2. To save your design configuration, click Save.

   The Save Configuration dialog appears.

3. Enter the name of the configuration, then click Save in the Save Configuration dialog. This saves your design to the configuration specified, and then exits the AvanWaves application.
Working With Designs: Exiting the Design

3-10
AvanWaves User Interface

This chapter describes the AvanWaves user interface, which includes the command line invocation, mouse operations, and the menus and tools used to perform operations on the simulation results. A list of keyboard shortcuts also is provided for the most commonly used commands.
Invoking AvanWaves

AvanWaves is invoked on the command line using different options. The full command line syntax is:

```
awaves [[-i][-plot][-d] <path><design_name> [-c <config_name>]]
[ -laf ( windows|openlook|motif ) ]
```

After you invoke the awaves command, the copyright information appears first, as shown in Figure 4-1, then is replaced with the Results Display window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-d &lt;design_name&gt;</td>
<td>Name of the design to open on invoking AvanWaves. Use HSPICE file extensions to specify the design name, such as .sp, .lis, .tr0, .tr1, .tr2, .ac0, .ac1, .ac2. An example of a design name is design1.sp.</td>
</tr>
</tbody>
</table>
| -c <config_name> | Specifies that a previously saved configuration for the current design is to be used upon the initialization of AvanWaves. The -d option with the design name corresponding to the configuration name must be specified on the command line. For example, if D1.sav/BodePlot.cfg is saved in a previous session, then to open the design and the saved configuration you can use one of the following command line options:
   - awaves -d D1 -c BodePlot
   - awaves -d /mytop/D1 -c BodePlot
   - laf [windows|openlook|motif]
   Specifies the window manager style to use. Default is Motif. |
| -i            | Directly open the “Awaves Command User Interface” windows when you open awaves. |
| -plot         | When you open awaves, the plot mode is Continuous. The default plot mode is Monotonic. |
Using the Mouse

Use the mouse to select items and menu options. Table 4-2 describes the use of the mouse buttons for Motif UNIX system users.

Table 4-2  Using Mouse Buttons with AvanWaves

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select item (“click”)</td>
<td>Click the left mouse button on the item to select it. This mouse button performs operations inside panels, such as measures and zooming.</td>
</tr>
<tr>
<td>Select menu (“select”)</td>
<td>Use the right mouse button to select from a menu, including context-sensitive menus.</td>
</tr>
<tr>
<td>Double-click</td>
<td>Using the left mouse button, click twice on the item to select or display. This action opens or expands an item.</td>
</tr>
<tr>
<td>Drag and drop</td>
<td>Using the left mouse button, click on the item to select it. Then press and hold down the middle mouse button while dragging the selected item. Release the button when the item is in the desired location.</td>
</tr>
<tr>
<td>Multi-select</td>
<td>While pressing Control, click on the desired items one after the other with the left mouse button. The group of items is selected.</td>
</tr>
<tr>
<td>Range select</td>
<td>Hold down the left mouse button and drag the mouse over the required range, then release the mouse button.</td>
</tr>
</tbody>
</table>
Tools

Table 4-3 lists tools available in the AvanWaves user interface.

Table 4-3  AvanWaves Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Results Browser</td>
<td>Displays available analysis files and types for a particular design</td>
</tr>
<tr>
<td>Results Display window</td>
<td>Main window; displays waveforms and related information</td>
</tr>
<tr>
<td>Expression Handler</td>
<td>Creates expressions for analyzing simulation results</td>
</tr>
<tr>
<td>Macro Builder</td>
<td>Dialog box for creating macros to use in your expressions</td>
</tr>
<tr>
<td>Print</td>
<td>Controls printing of the contents of a panel</td>
</tr>
<tr>
<td>Preferences</td>
<td>Sets general application preferences such as foreground and background color, font, and waveform display attributes</td>
</tr>
<tr>
<td>Sweep Filter</td>
<td>Dialog box for selecting parameters for displaying waveforms</td>
</tr>
</tbody>
</table>

Results Browser

The Results Browser lists all available HSPICE simulation data for the current design, by analysis type.

Figure 4-2  Results Browser
The next sections describe the components of the **Results Browser**.

### Current Design Field and Scroll List

The path to the current design is displayed in this field at the top of the **Results Browser**. An analysis label \( \text{tr0 through trn, ac0 through acn, sw0 through swn} \), is associated with each set of analysis data for the current design and displayed in the scroll list. Each analysis label is followed by a description consisting of a simulation type and title. The title is derived from the first line of the input file to HSPICE or the title specified on the `.ALTER` statement.

To select an analysis, click on the description associated with its label. The types of data available for the current analysis are listed in the Types area of the window, and the variable names are listed in the **Curves** area. You can change the contents of the Curves field by selecting other analyses in the Types list.

### Hierarchy Browser Scroll List

You can use the **Hierarchy Browser** to reduce the number of nodes that you see during curve selection in the **Results Browser** window. The Hierarchy Browser is a listbox in the **Result Browser**, as shown in Figure 4-3. This box displays the subcircuit hierarchy of a design. AvanWaves reads hierarchy information from either the `<design>.lis` or `<design>.pa0` output files from the HSPICE run. Not all circuits have a subcircuit hierarchy. If there is no hierarchy in the design, the hierarchy window is blank.

Subcircuits are shown in the form “instance_name: cell_name” if the `.lis` file is available. If only the `.pa0` file is available, only the instance name is shown. The `.pa0` file does not contain cell names.
You can perform two types of operations with the hierarchy window.

- Subcircuit hierarchies may be turned on and off by double clicking the parent.
- The set of subcircuits from which nodes are displayed is chosen by selecting subcircuits in the hierarchy window. Multiple subcircuits can be chosen by using the **Multi-select** or **Range select** features (see Using the Mouse on page 4-3).

**Figure 4-3  Hierarchy Browser with Multiple Subcircuits Selected**

**Types Scroll List**

The **Types** list displays the types of data available in your current analysis. Selecting the data type changes the contents of the **Curves** list to indicate the data available.

Click on one of the **Types** in the list to select it.
Curves Scroll List

The Curves area lists the data that is available for a selected type of analysis. After you select a data type in the Types area, a list of available data is displayed in the Curves scroll list.

To display the waveform for the curves, do either of the following:

- Select the required curves and drag the selections into a panel.
- Double-clicking on a node to display it in the selected panel.

Current X-Axis Selector

The Current X-Axis represents the variable and units to be used on the horizontal axis to display the waveform in the panel. The default X-Axis is the first independent variable in the Types list. You can modify or change your X-Axis variable as follows:

1. Drag a curve from the Curves section into the Current X-Axis box.
2. Select a curve and click Apply in the Current X-Axis box.
   
   The X-Axis used with this curve is now used as the Current X-Axis variable for the selected curve.
3. Click Default. This resets the value to the default value.
   
   The default value is the first variable in the Types list.
Filter Selector

The Filter selects data points based on criteria you enter for displaying in the Curves area. You can enter your selection criteria in the Filter field. Regular UNIX expressions ( *, . ) are accepted. Click Apply to apply your selection as a filter for the curves. Click Reset to display the default values in the curves area for your analysis.

Results Display Window

The Results Display window is the primary application window containing the menus, options, functions, and tools that you need to perform your simulation analysis. The Results Display window contains these components:

- Menu bar
- Speed bar
- Panel(s)
- Wave List
- Context-sensitive menus

The components of the Results Display window are described in the following sections.
The Window banner conforms to the standards of the resident window manager for your machine, such as Motif or OpenLook.

**Menu Bar**

The Menu bar is located at the top of the Results Display window and contains six pull-down menus and a Help button.

**Figure 4-5  Menu Bar**

The Menu bar contains these pop-up menus:

*Table 4-4  Speed Bar Menu*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design</td>
<td>Use to open and close a design, exit from a design, and display your current design.</td>
</tr>
<tr>
<td>Panels</td>
<td>Adds, deletes, hides and updates panels.</td>
</tr>
<tr>
<td>Window</td>
<td>Performs zooming and panning operations. These operations change the view in the panel.</td>
</tr>
</tbody>
</table>
Table 4-4  Speed Bar Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Measure</td>
<td>Performs point or point-to-point measurements on waveforms and deletes measurements.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Opens, saves, and deletes configurations.</td>
</tr>
<tr>
<td>Tools</td>
<td>Provides tools to perform analyses of your design.</td>
</tr>
<tr>
<td>Help</td>
<td>Provides on-line Help for AvanWaves.</td>
</tr>
</tbody>
</table>

The speed bar is located between the menu bar and the panel. It contains the following two types of items:

- Accelerator icons are used to make a quick selection of the **Results Browser**, **Expression Handler**, and **Print** functions. To select a function, click on the icon representing the function to open the associated dialog box.

- The **X-Y** coordinate display is used to display the position of the cursor during a measure operation. The X and Y coordinates of the cursor, shown on a waveform by the measure markers, are displayed in the boxes.

Figure 4-6  Speed Bar
Panel

Panels contain waveform displays in the AvanWaves **Results Display** window. A panel consists of a panel name, a Waveform Display area, an **X-Axis** and a **Y-Axis**, and a **Wave List**. The waveforms can be raw simulation data, measurements, or results of an analysis using expressions and operations on simulation data. A panel also has two context-sensitive pop-up menus associated with it. Panels can be added to or deleted from the **Results Display** window. Panels can be switched from one view type to another. You can save all information and status of a panel in a “configuration.”

**Figure 4-7  Panel**

![Panel Image]

**Table 4-5  Panel Components**

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panel name</td>
<td>Each new panel is opened with a default panel name such as ‘Panel 1’. You can change the panel name by deleting the default name and typing a new one. Panel names are displayed in the Panel List in the Panel pull-down menu. To delete a particular panel, select the panel name and click the Delete key.</td>
</tr>
<tr>
<td>Waveform Display area</td>
<td>the display area inside the panel where simulation data and analyses are displayed.</td>
</tr>
</tbody>
</table>
Each waveform has a unique color associated with it as an identifier. The color used in the waveform is the same color used to identify it in the Wave List. There is a standard set of colors assigned to waveforms as they are added to a display. The color set can be modified through the Preference option on the Tools menu.

You can use eight different colors at a time from a set of 16 colors. Waveform names can be no longer than sixteen characters in length, according to the HSPICE limit for relative waveform names.

Panels also can be hidden from view. If the number of panels displayed has reached the limit of eight, then each new panel above the maximum number is added to the Panel List as a hidden panel. Hidden panels are grayed out in the list. Panels currently displayed are highlighted in the list. To display a hidden panel, one of the panels currently displayed must either be hidden or deleted. These operations can be selected from the panels menu.

Note: You must select a panel by clicking in the panel before you perform an operation on it. A number of panels may be selected at a time by holding down the Control key while selecting the panels.

Table 4-5 Panel Components

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X-Axis</td>
<td>The horizontal X-Axis and its units display when the panel shows waveform data. A context-sensitive menu is associated with this axis. You can select this menu by pressing the right mouse button on the X-Axis. You can change the scale of the X-Axis display.</td>
</tr>
<tr>
<td>Y-Axis</td>
<td>The vertical Y-Axis and its units display when the panel shows waveform data. A context-sensitive menu is associated with this axis. You can select this menu by pressing the right mouse button on the Y-Axis. You can change the scale of the Y-Axis display.</td>
</tr>
</tbody>
</table>
Add Label

Use the Panels > Add Label utility to add your own labels to waveforms:

1. Click the left mouse button on Add Label, or type Ctrl-L, to display the Label Name dialog window.

2. Type your label into the Label: field of the Label Name window.

3. Click Apply to preserve the Label Name window if you want to apply another label after this one. Click OK If your label is either singular, or the last one of a set. When you move your cursor into the waveform display area, AvanWaves displays your label with your cursor arrow.

4. Click the left mouse button to place the label in any position in the display area.

Delete Label

Delete labels using Panels >> Delete Label. Select the label by clicking on it with the left mouse button and then click on Delete Label, or type Ctrl-2, to delete it.

Wave List

The Wave List is located on the left side of the Results Display window associated with each panel. All waveforms currently displayed in the waveform display area of the panel are listed. You can scroll through the Wave List if not all waveform names are visible.

Context-Sensitive Menus

Context-sensitive menus are pop-up menus that are available in a particular area of the panel. That is, a particular pop-up menu appears depending on the location of the cursor in the window. The
areas that have context-sensitive menus in the **Results Display** window are the **X-Axis**, the **Y-Axis**, and inside the waveform display area. Activate the context-sensitive menus by clicking in the context-sensitive area with the right mouse button.

**Figure 4-8  Context-Sensitive Menus**

In X- and Y-Axis areas

| Font…          | Full               |
|                | Zoom              |
|                | Set Zoom…         |
|                | Pan               |
|                | Set Pan…          |
|                | Set Grid…         |
|                | Monotonic Plot…   |
|                | Hide Title Bar    |
|                | Grid Off          |
|                | Sweep Filter      |
|                | Measure Preferences… |
|                | Stacked Mode      |

In waveform display areas

| Zoom In X          | Pan X               |
| Zoom Out X         | Pan X/Y             |
| Zoom In Y          |                         |
| Zoom Out Y         |                         |
| Zoom In X/Y        |                         |

**Context-Sensitive Menus in X-Axis and Y-Axis Areas**

The context-sensitive menus for the **X-Axis** and **Y-Axis** provide the option to change the scale used in the graph area. Select this option to display a dialog box with toggle buttons from which you can choose a **Linear** or **Logarithmic** scale. Select the scale you want with any of the mouse buttons, then click **Apply** to enforce it.
Context-Sensitive Menus in Waveform Display Areas

The context-sensitive menu for the waveform display area provides all the options available on the Window menu in the main menu bar, in addition to the following options:

Table 4-6  Context-Sensitive Menu Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Zoom</td>
<td>Calls up a dialog box in which you can set values for zooming. The X-Axis and Y-Axis scales are defined here. You can set specific zooming options, having minimum and maximum values.</td>
</tr>
<tr>
<td>Set Pan</td>
<td>Calls up the Set Local Pan dialog box where you can set values for local panning. You can enter values for your axis here.</td>
</tr>
<tr>
<td>Monotonic/Continuous Plot</td>
<td>Alters the display of your waveform.</td>
</tr>
<tr>
<td>Grid On/Off</td>
<td>Enables you to turn grid line on and off in the panel.</td>
</tr>
<tr>
<td>Sweep Filter</td>
<td>Selects the data set to be displayed.</td>
</tr>
<tr>
<td>Measure Preference</td>
<td>Enables you to set the preferences for performing measure operations.</td>
</tr>
<tr>
<td>Stacked Mode</td>
<td>Displays curves one above the other with each having its own Y-Axis, rather than overlaying the curves on a single Y-Axis.</td>
</tr>
</tbody>
</table>

For further information about these commands, see the Command Summary section in Appendix A.

Expression Builder

You can use the Expression Builder to create expressions containing functions, variables, operators, and macros. Expressions are given names and added to the Expressions list.

Enter the Expression Builder by selecting Tools >> Expressions from the Results Display window.
Macros also can be created and are added to the Macros list. The results of evaluating expressions can be displayed as waveforms in the Results Display window.

The next sections describe the components of the Expression Builder window:

**Expression Field**

Enter the text for an expression in the Expression field. An expression consists of functions, macros, arguments, and operators. Variables can be selected from the simulation results found in the Curves section of the Results Browser. You can use expressions to build more complex expressions.
**Result Field**

Enter a name for the expression in the **Result** field. The expression is saved under this name so that it can be used later. The name is added to the **Expressions** list.

**Clear Button**

Clears the Expression field and the **Result** field.

**Functions List**

The **Functions** list shows all the system-defined functions that are available for use in creating expressions and macros. Appendix B describes the functions and operators available in AvanWaves.

**Operators List**

The **Operators** list shows all the predefined operators that are available for use in building expressions and macros in AvanWaves. The following are the types of operators:

- Arithmetic (+, -, *, /) — return analog waveforms
- Comparison (>, <, <=, >=, !=, ==) — return logical waveform results (1 or 0)
- Boolean combination (&&, ||, !) — return logical waveform results (1 or 0)
- Conditional (expr1 ? expr2 : expr3) — analog value (first parameter is logical)

**Expressions List**

The **Expressions** list shows all user-defined expressions.
**Macros List**

The *Macros* list shows all the macros created or loaded into AvanWaves. You can select macros from this list, to use in expressions, the same way that functions are used in expressions.

**Buttons**

*Table 4-7 Expression Builder Buttons*

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Displays the Options Menu</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to get on-line Help for the current window.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operations.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click Apply to apply the changes to the expressions and macros.</td>
</tr>
</tbody>
</table>

**Options Menu**

The *Options* pop-up menu provides options for adding, editing, loading, and saving user-defined functions for expressions. The following options are available in the *Macro* pop-up menu:

*Table 4-8 Options Menu*

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Options &gt;&gt; Add Macro</td>
<td>Creates a new macro and adds it to the <em>Macros</em> list.</td>
</tr>
<tr>
<td>Options &gt;&gt; Edit Macros</td>
<td>Enables you to edit the macro that is currently selected in the <em>Macros</em> list.</td>
</tr>
<tr>
<td>Options &gt;&gt; Load Macros</td>
<td>Loads previously defined macros into the <em>Macros</em> list to be used in creating expressions.</td>
</tr>
<tr>
<td>Options &gt;&gt; Save Macros</td>
<td>Saves the current macro to a file.</td>
</tr>
<tr>
<td>Options &gt;&gt; Delete Expression</td>
<td>Removes the specified expression.</td>
</tr>
</tbody>
</table>
Add/Edit Macro Dialog

The **Add Macro** dialog is used to add macros to the **Macros** list in the **Expression Builder** window. These macros can be used later in expressions.

The Edit Macro dialog is used to edit previously defined macros. A macro must be selected from the list of available macros in the Expression Builder window before selecting this option. The macro selected for editing is displayed in the **Edit Macro** dialog when the dialog opens.

The **Edit Macro** dialog has the same user interface as the **Add Macro** dialog. The following is the user interface for both options.

*Figure 4-10  Add/Edit Macro Dialog*
Load/Save Macro Dialog

The **Load Macro** function is used to load previously saved macros into the Macros list. To save macros, use a `.mac` extension.

Note: To load a macro that you have saved using a different extension you must select the **Filter >> All Files** option in the Load Macros dialog to display all the files in the list.

The **Save Macro** dialog allows you to save the macros that you created during the current session to a file. This allows you to load and use them in another AvanWaves session with other designs.
The **Load Macro** dialog has the same user interface as the **Save Macro** dialog. The user interface for both options is described below.

**Figure 4-11  Load/Save Macro Dialog**

![Load/Save Macro Dialog](image)

The components of the **Load Macro** and **Save Macro** dialogs are described below.

**Load Macros/Save Macros Menus**

**History**

Select this menu item to get a list of the most recent paths used for loading or saving macros. Select one of the paths from this list to load a macro contained in the path or to save a macro to a file at that location. The History list is updated each time you load or save a macro, and it is saved between AvanWaves sessions. The default path is that from which you started the AvanWaves application.
Special

Use this menu with the History menu.

Table 4-11 Special Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Returns you to your home directory.</td>
</tr>
<tr>
<td>Mark</td>
<td>Marks a directory location for the history list.</td>
</tr>
<tr>
<td>Unmark</td>
<td>Removes the current directory location from the marked list.</td>
</tr>
</tbody>
</table>

View

The View option selects the order in which file names display in the file list.

Table 4-12 View Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>by name</td>
<td>Lists the files in alphabetical order by name.</td>
</tr>
<tr>
<td>by date modified</td>
<td>Lists the files according to the last date they were modified.</td>
</tr>
<tr>
<td>by date created</td>
<td>Lists the files by the date created.</td>
</tr>
</tbody>
</table>

Filter

The Filter option allows you to limit the number of files displayed by selecting the file types in the File List. The menu has two buttons. A button that has been clicked marks a selection. A button that is not depressed means that it has not been selected.

Table 4-13 Filter Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macro Definitions</td>
<td>Display macro files only.</td>
</tr>
<tr>
<td>All Files</td>
<td>Display all the files in the current directory.</td>
</tr>
</tbody>
</table>
Open/Save Field

Open/Save is a text field where you can enter the path to the file you want to open or enter a location where you can save the macro.

Buttons

Table 4-14  Load Macros/Save Macros Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click <strong>OK</strong> to apply the selection and close the Macro Definitions window.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click <strong>Apply</strong> to apply the selection.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click <strong>Cancel</strong> to cancel the current operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click <strong>Help</strong> to view on-line Help about the current dialog.</td>
</tr>
</tbody>
</table>

Sweep Filter

In AvanWaves, a sweep is a set of response data with a variation in the value of one of the parameters, such as voltage, resistance, or temperature. To analyze designs, you can select and display a set of output data from HSPICE simulations (“sweeps”).

The **Sweep Filter** is used to display the values of a variable for its changing parameters. Sweep increments are displayed on a panel-by-panel basis. The title in the **Sweep Filter** dialog shows the name of the panel to which the sweeps belong.

Figure 4-12  Sweep Filter

![Sweep Filter Diagram]
The display area of the filter shows the sweep increments associated with a particular waveform in the current design.

The first entry in the first column in the display area acts as a toggle for selecting or deselecting the sweep increments in the adjoining row. The sweep increments can be selected individually by clicking on them using the left mouse button. The sweep increments also can be selected in groups by holding the Control button down while selecting each one using the left mouse button.

Table 4-15  Sweep Filter Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click OK after selecting the sweep(s) you want to display. This displays the sweep(s) in the waveform display area of the panel and closes the Sweep Filter.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click Apply after selecting the sweeps from the list to display them in a panel. You must click OK or press Return to close the Sweep Filter.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operation. The Sweep Filter closes.</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to view the AvanWaves on-line Help about the current dialog box.</td>
</tr>
</tbody>
</table>

Print Dialog

The Print dialog window allows you to print the waveforms displayed in the panels, along with the measurement data and any labels annotating the waveform. Both open and hidden panels can be printed.
Figure 4-13  Print Dialog with Print to Printer Selection

Figure 4-14  Print Dialog with Print to File Selection
## Print

To make printing selections, click on the buttons in the Print dialog:

### Table 4-16  Print Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Panels            | Click **All** to print all the panels, including the panels in the **Results Display** area, as well as the hidden panels.  
|                   | Click **Selected** to print panels that you have selected from the **Results Display** area and the **Panel List**.                           |
| Panels per Page   | Click **One** to print one panel per printed page. One panel is printed per page for each of the panels selected. There is no maximum number of panels that can be printed using this option. An extended legend containing information about the waveform is displayed across the end of the print, including the design name, the design type, the waveform name, and the symbol used to represent data points on this waveform.  
|                   | Click **Many** to print multiple panels on one page. Up to eight selected panels can be printed on a page. An error message is displayed if more than eight panels are selected using the Many option in the Print window. In this case you must go back and reset your print options. A legend is printed out for each panel containing the waveform name, the design analysis tag name, and the symbol used for plotting the data points. |
| Step X View       | Select this toggle if you have a waveform whose view has been altered due to zooming and you want to print the whole waveform. It takes the existing X zoom factor and steps along the X axis from the beginning to the end of the waveform, printing consecutive sections of the waveform. Each section is printed on a separate page. |
| Print To          | Click **Printer** to print a hard copy. This output format depends on the selected print driver. A number of print options are available such as **PostScript**, **Encapsulated PostScript**, **Generic Output**, and **All Files**.  
|                   | If you click **File** to send the output to a file in PostScript format, this command changes the printer string input field to a set of radio buttons. Refer to [Figure 4-14 on page 4-25](#). |
| Printer Format    | Generates output file of specific printer's format.                                                                                         |
| PS                | Postscript format output.                                                                                                                    |
| EPS               | Encapsulated Postscript output.                                                                                                               |
| Printer Name      | Enter the network name of the printer in this text field.                                                                                   |
| Size              | Select the page size to print a hard copy.                                                                                                  |
Set Zoom

Select the **Window > Set Zoom** option to display the **Zoom Selected Panels** dialog window shown in **Figure 4-15**. This window lets you set the zoom factor for zooming in and out of selected areas on the waveform displayed in a panel. The view of the waveform is changed by the ranges selected. The **Set Local Zoom** option is available on the context-sensitive menu in the panel. Click using the right mouse button to display this menu.

**Table 4-16 Print Menu (Continued)**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td>Click either <strong>Landscape</strong> or <strong>Portrait</strong> as the page orientation for printing.</td>
</tr>
<tr>
<td>Color</td>
<td>• Click <strong>Color</strong> to print to a color printer.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Monochrome</strong> to get a black and white print.</td>
</tr>
</tbody>
</table>

**Table 4-17 Print Buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print</td>
<td>Click <strong>Print</strong> to print the current file selection. If the output is to a file, a dialog box asks you to specify the location and file name for the output.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click <strong>Cancel</strong> to cancel the current print operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click <strong>Help</strong> to view on-line Help about the current dialog.</td>
</tr>
</tbody>
</table>

**Figure 4-15 Zoom Selected Panels**
Set Pan

The **Set Local Pan** dialog allows you to set the values for panning across the waveform displayed in the panel. Panning is very similar to a scrolling operation and you can pan horizontally or vertically by an amount you specify. Entering a positive delta value for the X-Axis shifts the waveform to the right. Entering a negative delta value for the X-Axis shifts the waveform to the left. Entering a positive delta value for the Y-Axis shifts the waveform upward. Entering a negative delta value for the X-Axis shifts the waveform downward.

The **Set Pan** option is available on the context-sensitive menu in the panel. Click using the right mouse button to display this menu.

Note: Panning operations are performed independently on each axis. When displaying two Y-axes you can set different panning amounts for each axis.

---

### Table 4-18  Zoom Selected Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Axis</td>
<td>Lists the axes displayed in the <strong>Results Display</strong> window. You can have one X-Axis and up to two Y-axes displayed.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Contains the value of the lower limits of each axis. A pop-up menu containing the scale factors is associated with this field.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Enter the value of the upper limit of each axis. A pop-up menu containing the scale factors is associated with this field.</td>
</tr>
</tbody>
</table>

### Table 4-19  Zoom Selected Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click <strong>OK</strong> to change the view in the panel to that specified.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click <strong>Apply</strong> to change the range of the axis to that specified in the <strong>Set Local Zoom</strong> dialog. You must click <strong>OK</strong> or press <strong>Return</strong> to close the <strong>Set Local Zoom</strong> dialog.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click <strong>Cancel</strong> to cancel the current operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click <strong>Help</strong> to view on-line Help about the current dialog.</td>
</tr>
</tbody>
</table>
Figure 4-16  Set Local Pan

![Diagram of Set Local Pan interface]

Table 4-20  Set Local Pan Fields

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Axis</td>
<td>Lists the axes displayed in the Results Display window. You can have one X-Axis and up to two Y-axes displayed.</td>
</tr>
<tr>
<td>Delta</td>
<td>Contains the value of the amount that each axis is to be shifted. A pop-up menu containing the scale factors is associated with this field.</td>
</tr>
</tbody>
</table>

Table 4-21  Set Local Pan Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click OK to change the view in the panel to the view specified.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click Apply to change the range of the axis to the range specified in the Set Local Pan dialog. You must click OK or press Return to close the Set Local Pan dialog.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to view on-line Help about the current dialog.</td>
</tr>
</tbody>
</table>
Set Grid

Use the Set Grid dialog to set vertical grid line values in the panel.

1. Select the Set Grid option from the context-sensitive menu in the panel.

2. Click the right mouse button to display the menu.

Figure 4-17 Test Update Dialog

3. To set the start point in which the grid line display, enter a value for GridStart.

4. To set the gap between neighboring grid lines, enter a value for GridSpace.

Note: Whenever you use any zooming operations, reset the GridStart and GridSpace values, according to the start point value of the x_axis.

Table 4-22 Test Update Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GridStart</td>
<td>Specifies the start point, where the first grid line displays.</td>
</tr>
<tr>
<td>GridSpace</td>
<td>Specifies the distance between two grid lines.</td>
</tr>
</tbody>
</table>
Table 4-23  Test Update Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click OK to change the view in the panel to the view specified.</td>
</tr>
<tr>
<td>Apply</td>
<td>Click Apply to change the displayed grid lines to the range specified in the Set Grid dialog. You must click OK or press Return to close the Set Grid dialog.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click Cancel to cancel the current operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click Help to view on-line Help about the current dialog.</td>
</tr>
</tbody>
</table>

Measure Label Options

Use this dialog window to choose your preferred label attributes. See Measure Label Options for descriptions of the options.

Measure Preferences

From the Results Display window, select Measure > Measure Preferences to display the Set Measure Preferences window. This window allows you to select different measure options, as well as to select Snap mode when measuring using one or two points. See Figure 5-1 for a full description.

The Select Preference Window

From the Results Display window main menu, select Tools > Preferences to display the Select Preferences window. This window contains a set of menu options that provide general information on the AvanWaves application. Select options on the menus or click on the lists in the dialog box to set the preferences information.
The menu options available in the Select Preference window are.

**Table 4-24  Select Preferences Menu Options**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt;&gt; Close Window</td>
<td>closes the Select Preferences window</td>
</tr>
<tr>
<td>Edit &gt;&gt; Selected</td>
<td>(not implemented in this release)</td>
</tr>
<tr>
<td>Edit &gt;&gt; Application &gt;&gt; About</td>
<td>displays the About box for the AvanWaves application, giving version and copyright information</td>
</tr>
<tr>
<td>Edit &gt;&gt; Application &gt;&gt; General</td>
<td>displays a dialog box for setting general application preferences for font, foreground, and background colors</td>
</tr>
<tr>
<td>Edit &gt;&gt; Analysis &gt;&gt; Curves</td>
<td>allows you to set color preferences and continuity for displaying waveforms, the symbol type, and frequency for displaying data points on waveforms</td>
</tr>
</tbody>
</table>
Set General Preferences Dialog

From the **Select Preferences** window, click on **Application > General** to show the **Set General Preferences** dialog window.

The **Set General Preferences** dialog allows you to set preferences for foreground and background color and also select the font used for menu and window names and for messages.

*Figure 4-19  Set General Preferences Dialog*

*Table 4-25  Set General Preferences Buttons*

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Foreground</td>
<td>Opens the <strong>Color Preference Chooser</strong> to set the foreground color.</td>
</tr>
<tr>
<td>Set Background</td>
<td>Opens the <strong>Color Preference Chooser</strong> to set the background color.</td>
</tr>
<tr>
<td>Set Font</td>
<td>Opens the <strong>Font Preference Chooser</strong> to select a font to use in AvanWaves.</td>
</tr>
<tr>
<td>OK</td>
<td>Click <strong>OK</strong> to apply the selections that you made.</td>
</tr>
<tr>
<td>Defaults</td>
<td>Click <strong>Defaults</strong> to use the default settings for each item in the window.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click <strong>Cancel</strong> to cancel the current operation and make no changes.</td>
</tr>
<tr>
<td>Help</td>
<td>Click <strong>Help</strong> to view on-line Help about the current dialog.</td>
</tr>
</tbody>
</table>
Set Analysis Preferences Window

From the Select Preferences window, click on Analysis >Curves to show the Set Analysis Preferences dialog window.

The Set Analysis Preferences window is used to select the following waveform display attributes:

- The color of the displayed waveform
- Whether the continuity option is to be displayed
- Line style that represents the displayed waveform
- Symbol that represents the displayed data points on a waveform
- Frequency with which the symbols are placed on a waveform

Figure 4-20  Set Analysis Preferences Window
**Curve**

The **Curve** number indicates the order in which the colors are used to display the waveforms in a panel. Eight colors are allowed, and a cycle is made on the eight colors.

**Color**

Eight colors are used to display waveforms in the panels in the **Results Display** window. The waveforms in each panel are considered separately.

The colors are organized in a hierarchy, the color corresponding to **Curve 1** being used for the first curve displayed, and the color corresponding to **Curve 8** being that used for the last curve displayed. If there are more than eight curves, the first color is used again. A default set of colors is available initially. You can change the colors in the set and the order in which they are used.

Click on a color button to show the **Color Preference Chooser** and select your color choice.

**Continuity**

Continuity is a toggle button that you can select to display connections between the data points of a waveform. The full waveform and the symbols representing the set of selected data points for the analysis are displayed in the panel. Setting continuity off displays only the symbols representing the data points and no connections. The default value is on. A single click toggles the feature on or off.
**Line Style**

The line style used to represent each curve is displayed in each panel. Default line style are automatically assigned to the basic set of eight curves.

Click on a **Line Style** button to show the **Line Style Chooser** and select from any one of the eight line styles.

To distinguish between different waveforms on monochrome hardcopy plots, you can use a different line style for each waveform.

**Symbol**

The symbol used to represent the data points on each curve is selected with this function. Default symbols are automatically assigned to the basic set of eight curves.

Click on a **Symbol** button to show the **Symbol Chooser** and select from any one of nine symbols.

To distinguish different waveforms on monochrome hardcopy plots, you can use a different symbol for each waveform.

**Frequency**

The **Frequency** setting determines how many of the available data points are displayed on a waveform. A frequency of two displays every other data point with a symbol. A frequency setting of 0 means that only the first data point on the curve is displayed.

Type a new number in the **Frequency** field to make a change.

**Setting your Preference**

Use the following buttons in the **Set Analysis Preferences** window to register your choices.
Symbol Chooser

The **Symbol Chooser** displays a list of nine symbols that can be used to represent the data points on your waveform. The name of the selected curve is displayed in the title of this window.

**Figure 4-21  Symbol Chooser**

![Symbol Chooser](image)

**Table 4-26  Symbol Chooser Buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click <strong>OK</strong> to change the current symbol to the newly selected symbol.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click <strong>Cancel</strong> to cancel the current operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click <strong>Help</strong> to display the AvanWaves on-line <strong>Help</strong> for this window.</td>
</tr>
</tbody>
</table>
**Line Style Chooser**

The **Line Style Chooser** displays a list of eight line styles that can be used to represent the waveform. The name of the selected curve is displayed in the title of this window.

**Figure 4-22  Line Style Chooser**

![Line Style Chooser Window]

**Table 4-27  Line Style Chooser Buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Click <strong>OK</strong> to change the current symbol to the newly selected symbol.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Click <strong>Cancel</strong> to cancel the current operation.</td>
</tr>
<tr>
<td>Help</td>
<td>Click <strong>Help</strong> to display the AvanWaves on-line Help for this window.</td>
</tr>
</tbody>
</table>
**Keyboard Shortcuts and Hotkeys**

Keyboard shortcuts and hotkeys are used to accelerate specific operations that are normally invoked using a series of menu selections. Table 4-28 below lists the keyboard keys that are bound to particular functions in AvanWaves.

### Table 4-28 Hotkey Definitions

<table>
<thead>
<tr>
<th>Subject</th>
<th>Keystrokes</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design</td>
<td>Ctrl + o</td>
<td>Open Design</td>
</tr>
<tr>
<td></td>
<td>Ctrl + c</td>
<td>Close Design</td>
</tr>
<tr>
<td></td>
<td>Ctrl + 6</td>
<td>Select current design</td>
</tr>
<tr>
<td>Panels</td>
<td>Ctrl + a</td>
<td>Add Panel</td>
</tr>
<tr>
<td></td>
<td>Ctrl 1</td>
<td>Hide Panel</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Del</td>
<td>Delete Panel</td>
</tr>
<tr>
<td></td>
<td>Del</td>
<td>Delete selected curve in selected panel</td>
</tr>
<tr>
<td></td>
<td>Ctrl u</td>
<td>Update</td>
</tr>
<tr>
<td></td>
<td>Ctrl i</td>
<td>Add Label</td>
</tr>
<tr>
<td></td>
<td>Ctrl 2</td>
<td>Delete Label</td>
</tr>
<tr>
<td>Window</td>
<td>Ctrl + f</td>
<td>Full Zoom (display complete data set)</td>
</tr>
<tr>
<td></td>
<td>Ctrl + x</td>
<td>Zoom In X</td>
</tr>
<tr>
<td></td>
<td>Ctrl + 3</td>
<td>Zoom Out X</td>
</tr>
<tr>
<td></td>
<td>Ctrl + y</td>
<td>Zoom In Y</td>
</tr>
<tr>
<td></td>
<td>Ctrl + 4</td>
<td>Zoom Out Y</td>
</tr>
<tr>
<td></td>
<td>Ctrl + z</td>
<td>Zoom In X/Y</td>
</tr>
<tr>
<td></td>
<td>Ctrl + 5</td>
<td>Zoom Out X/Y</td>
</tr>
<tr>
<td></td>
<td>Ctrl + t</td>
<td>Last Zoom</td>
</tr>
<tr>
<td></td>
<td>Ctrl + s</td>
<td>Set Zoom</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Shift X</td>
<td>Pan X</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Shift Y</td>
<td>Pan Y</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Shift Z</td>
<td>Pan X/Y</td>
</tr>
<tr>
<td>Subject</td>
<td>Keystrokes</td>
<td>Function</td>
</tr>
<tr>
<td>-----------</td>
<td>------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Measure</td>
<td>Ctrl + 8</td>
<td>Measure Point</td>
</tr>
<tr>
<td></td>
<td>Ctrl + m</td>
<td>Measure Point to Point</td>
</tr>
<tr>
<td></td>
<td>Ctrl + 9</td>
<td>Delete Measure</td>
</tr>
<tr>
<td></td>
<td>Ctrl + d</td>
<td>Delete All Measures</td>
</tr>
<tr>
<td></td>
<td>Ctrl + g</td>
<td>Measure Label Options</td>
</tr>
<tr>
<td></td>
<td>Ctrl + i</td>
<td>Measure Preferences</td>
</tr>
<tr>
<td>Configuration</td>
<td>Ctrl + n</td>
<td>Open configuration</td>
</tr>
<tr>
<td></td>
<td>Ctrl + v</td>
<td>Save configuration</td>
</tr>
<tr>
<td>Tools</td>
<td>Ctrl + b</td>
<td>Display Results Browser</td>
</tr>
<tr>
<td></td>
<td>Ctrl + e</td>
<td>Display Expression Builder dialog</td>
</tr>
<tr>
<td></td>
<td>Ctrl + p</td>
<td>Display the Print dialog</td>
</tr>
<tr>
<td></td>
<td>Ctrl + Shift + u</td>
<td>Display Preference Manager dialog</td>
</tr>
<tr>
<td></td>
<td>Ctrl + h</td>
<td>Run HSPICE – displays the Run Manager dialog</td>
</tr>
</tbody>
</table>
Viewing Waveforms

This chapter describes the functions available in AvanWaves to change the view of the current waveforms displayed in panels. Views of waveforms are changed by selecting zooming and panning operations from the Windows menu.
Changing Views in a Panel

Use the Window menu for global operations. You can apply these operations to several selected panels at a time. Window menu options change the view of the waveform displayed in the panel.

**Full**

*Full* displays the complete waveform in the waveform display area.

**Zoom In X**

Select *Zoom In X* to magnify the area selected on the waveform. The panel view changes to the selected view. You can make selections only in relation to the X-axis. This is horizontal zooming.

To zoom into a specific area of the waveform:

1. In the *Results Display* window, select *Window > Zoom In X*.
   
   This displays a “magnifying glass” cursor inside the waveform display area in the Panel. This type of cursor is used to specify the direction (left or right) and the distance on the X-axis that you want to select for zooming in the waveform display.

2. Position the cursor at the start of the area you want to select. Then, holding the left mouse button down, drag the cursor over the distance you want to select for zooming. Release the button when you have selected the area.

   The line defines the waveform area to present in more detail. The previous panel view changes to the selected view.
**Zoom Out X**

Select **Zoom Out X** to reduce the results window scale horizontally. To zoom out in a waveform display:

1. In the **Results Display** window, select **Window > Zoom Out X**.
   
   This action displays a “magnifying glass” cursor inside the waveform display area of the panel. This cursor is used to specify the X-axis start coordinate and the amount of zoom-out required for the resultant display.

2. Position the cursor at the point you want to be the start of the zoomed-out display and, depress the left mouse button. Then generate a line by dragging the cursor from left to right over the section of display that you want to include in the result. Release this button to generate the new view.

   You can draw the line from right to left but the left-hand end of this line still becomes the start point for the resultant display.

3. AvanWaves zooms out the display to a new X-axis scale length equal to the ratio of X-axis scale length to the length of the line dragged by the mouse.

**Zoom In Y**

Select **Zoom In Y** to zoom into the area selected on the waveform. The panel view then changes to that of the selected view. You can make selections only in relation to the Y-axis. This is vertical zooming.

To zoom into a specific area of the waveform along the Y-axis:

1. In the **Results Display** window, select **Window > Zoom In Y**.

   This displays a magnifying glass cursor inside the waveform display area in the Panel. This type of cursor is used to specify the direction (up or down) and the distance on the Y-axis that you want to select for zooming in the waveform display.
2. Position the cursor at the start of the area you want to select. Then, holding the left mouse button down, drag the cursor over the distance you want to select for zooming. Release the button when you have selected the area.

The line defines the area of the waveform that you want presented in more detail. The previous panel view changes to the selected view.

**Zoom Out Y**

Select **Zoom Out Y** to display the results window to a reduced scale. This command provides only vertical zooming.

To zoom out in a waveform display:

1. In the **Results Display** window, select **Window > Zoom Out Y**.

   This action displays a “magnifying glass” cursor inside the waveform display area of the panel. This cursor is used to specify the Y-axis start coordinate and the amount of zoom-out required for the resultant display.

2. Position the cursor where you want to start the zoomed-out display. Press the left mouse button, generate a line by dragging the cursor from bottom to top over the section of display that you want to include in the result. Release this button to generate the new view. You can draw the line from top to bottom but the bottom end of this line becomes the start point for the resultant display.

   AvanWaves zooms out the display to a new Y-axis scale length equal to the ratio of Y-axis scale length to the length of the line dragged by the mouse.


**Zoom In X/Y**

Select **Zoom In X/Y** to zoom into the area selected. You can select in both directions. The panel view then changes to that of the selected view.

To zoom into a specific area of the waveform in relation to both the X-axis and the Y-axis:

1. In the **Results Display** window, select **Window > Zoom in X/Y**.
   
   This displays a magnifying glass cursor inside the waveform display area in the Panel. This type of cursor is used to specify the distance in the X and Y directions that you want to select for zooming in the waveform display.

2. Position the cursor at the start of the area you want to select. Then, holding the left mouse button down, drag the cursor over the distance you want to select for zooming. Release the button when you have selected the area.

   The line defines the area of the waveform that you want to zoom into. The previous panel view then changes to the selected view.

**Zoom Out X/Y**

Select **Zoom Out X/Y** to display the results window to a reduced area scale. This command zooms an area (horizontal and vertical).

To zoom out in a waveform display:

1. In the **Results Display** window, select **Window > Zoom Out X/Y**.

   This action displays a “magnifying glass” cursor inside the waveform display area of the panel. This cursor is used to specify the X-axis and Y-axis start coordinates and the amount of zoom-out required for the resultant display.
2. Position the cursor where you want to start the zoomed-out display. Press the left mouse button, generate a rectangle by dragging the cursor from left to right and bottom to top over the section of display that you want to include in the result. Release this button to generate the new view. You can draw the rectangle in the opposite direction but the bottom left-hand end of the rectangle still becomes the start point for the resultant display.

AvanWaves zooms out the display to new X-axis and Y-axis scale lengths equal to the ratios of X-axis and Y-axis scale lengths to the lengths of the rectangle sides that the mouse drags.

**Last Zoom**

Selecting **Last Zoom** returns to the previous zoom selection. When you select **Last Zoom**, the panel view changes to display the previously selected zoom area.

**Pan X**

Selecting **Pan X** displays a cross-shaped cursor inside the waveform display area. This type of cursor is used to specify the direction (right or left) and the distance on the X-axis that you want to move the waveform in the waveform display.

To pan in the X direction, select the direction and the distance that you want to move the waveform by dragging the cursor a specified amount to the right or left, while holding the left mouse button down. The waveform is shifted parallel to the X-axis.

**Pan Y**

**Pan Y** displays a cross-shaped cursor in the waveform display area. This cursor specifies the direction (up or down) and the distance on the Y-axis to move the waveform in the waveform display.
To pan in the Y direction, select the direction and the distance that you want to move the waveform by dragging the cursor a specified amount up or down, while holding the left mouse button down. The waveform is shifted parallel to the Y-axis.

**Pan X/Y**

Select **Pan X/Y** to display a cross-shaped cursor inside the waveform display area in the Panel. This type of cursor is used to specify the distance that you want to move the waveform in X direction (right or left) and the Y direction (up or down).

To pan in the X and Y directions, hold the left mouse button, and drag the cursor a specified amount in any direction. The waveform view shifts by the distance specified in the X and Y directions.

**Stacked/Overlay**

When AvanWaves is in overlay mode (default), it generates one X and one Y-Axis and draws each curve in that area. In overlay mode, AvanWaves combines a single X-Axis with a separate Y-Axis for each signal, so the curves stack one above the other on the screen.

Select **Stacked/Overlay Mode** to toggle between these two display formats. This functionality is also available in the pop-up menu, where the bottom entry is either **Stacked Mode** or **Overlay Mode**, depending on the mode to which you set AvanWaves.

Note: Each curve has its own Y-Axis, so you can zoom the Y axis of each plot in stacked mode. Switch to overlay mode to select a worst-case full-scale axis for all curves. Toggle back to stacked mode to restore the saved Y-Axis zoom factors on each curve.
Performing Measurements

You can use the Measure menu in the Results Display window. It contains six options:

- Point
- Point to Point
- Delete Measure
- Delete All Measures
- Measure Label
- Measure Preferences

Measure reads specific values from a waveform displayed in a panel. The Measure operation performed on a waveform can provide you with the X and Y coordinates of a point on a waveform displayed in the Results Display window, or the difference in the coordinates of two points selected on a waveform or between waveforms.

When you use Measure > Point or Measure > PointToPoint, the X- and Y-axis labels and the coordinates of the cursor location are shown in boxes on the right side of the Results window toolbar. The X-axis label is shown in the leftmost box, the X-axis value of the cursor location is shown in the next box, then the Y-axis label, and finally the Y-axis value of the cursor location.
Measure

The Measure option lets you interactively measure data on your waveform display. You can measure data on one waveform or between waveforms on the same panel. This interactive measure returns scalar results and displays them on the screen. To measure, place markers on one or more waveforms.

Table 5-1 Functions in Measure Menu

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point</td>
<td>Displays the X and Y coordinates for the point selected on a waveform, and the value of the derivative at that point.</td>
</tr>
<tr>
<td>PointToPoint</td>
<td>Displays the delta X, delta Y, and the slope values for the two points selected. Both Point and PointToPoint operations turn on the X/Y coordinate display in the upper right corner of the Results Display window.</td>
</tr>
<tr>
<td>Delete All</td>
<td>Removes all measures from all selected panels</td>
</tr>
<tr>
<td>Delete Measure</td>
<td>Removes the selected measure markers from the waveform display. To select a marker, hold down the Shift key and click with the left mouse button on the marker. This is a select/deselect toggle. To deselect a marker, perform the same operation again.</td>
</tr>
<tr>
<td>Measure Label Options</td>
<td>Sets the display items inside the measure label. The Measure Label Options dialog is displayed.</td>
</tr>
</tbody>
</table>

Anchor Cursor

Selecting this entry enables you to place a set of anchored cursors or adjustable measures on the display. One cursor will be dropped on the next left mouse button press, and the second on the following release of the button. Each of the cursors will appear as a vertical line through all panels that share the same units on the X-Axis.

Note: Because anchored cursors appear in all compatible panels, they allow convenient measurements between panels. The only requirement is units compatibility, not value compatibility, thus all time axes are considered compatible.
While being dragged and after being dropped, the first cursor indicates its X-Axis value at the top of the window and the value of every curve at the point where it crosses the cursor in a label positioned near that crossing. The second cursor indicates these values as well, but also includes a delta value that is the change in the value of that signal as measured from the first cursor.

After you place both cursors, to pick up either and move them again, left click on the curve, drag to a desired new location, then release it. For more-accurate relative measurements, duplicate a panel, zoom each panel in on a transition, and drop the anchored cursors until one appears in each zoomed in panel. During dragging, only values on the moved cursor update. Deltas update after you drop the cursor.

Only one pair of anchored cursors can be on the display at a time. Selecting this entry a second time removes the first pair and initiates placement of a replacement pair.

- Use **Remove Anchors** to remove the anchored cursors from the display.
- Use **Measure Preferences** (Figure 5-1) to select different measure options, and to select Snap mode when measuring using one or two points.
These preferences apply to all selected panels.

Table 5-2  Panel Preference Settings

<table>
<thead>
<tr>
<th>Preference Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set Snap All Values</td>
<td>Snap to interpolated points during measurement.</td>
</tr>
<tr>
<td>Set Snap Data Point</td>
<td>Snap to simulation points during measurement.</td>
</tr>
<tr>
<td>Set Lock All Angle</td>
<td>No limitation during measurement.</td>
</tr>
<tr>
<td>Set Lock Vertical At first point</td>
<td>Limit measurement to the X (horizontal) direction only.</td>
</tr>
<tr>
<td>Set Lock Horizontal At first point</td>
<td>Limit measurement to the Y (vertical) direction only.</td>
</tr>
<tr>
<td>Set Lock Vertical at X Value</td>
<td>Limit the measurement only on X direction, and lock to the value specified</td>
</tr>
<tr>
<td></td>
<td>in the string input field.</td>
</tr>
<tr>
<td>Set Lock Horizontal at Y Value</td>
<td>Limit the measurement only on Y direction, and lock to the value specified</td>
</tr>
<tr>
<td></td>
<td>in the string input field.</td>
</tr>
<tr>
<td>Precision</td>
<td>Precision in the measure label and X-Y coordinate display boxes, at the</td>
</tr>
<tr>
<td></td>
<td>upper right of the Results Display window.</td>
</tr>
</tbody>
</table>
Measure Label Dialog

Use the Measure Label Options dialog (Figure 5-2) to set the display item and features for the selected measure labels. All subsequent measures use the new settings specified in this dialog.

Table 5-3  Measure Label Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Title string for the measure label.</td>
</tr>
<tr>
<td>X1</td>
<td>Title for the X1 value.</td>
</tr>
<tr>
<td>Y1</td>
<td>Title for the Y1 value.</td>
</tr>
<tr>
<td>Current X</td>
<td>Title for the current X value (with label).</td>
</tr>
<tr>
<td>Current Y</td>
<td>Title for the current Y value (with label).</td>
</tr>
<tr>
<td>Delta X</td>
<td>String in front of the Delta X value, for two point measurement.</td>
</tr>
<tr>
<td>Delta Y</td>
<td>String in front of the Delta Y value, for two point measurement.</td>
</tr>
<tr>
<td>Slope</td>
<td>String in front of the Slope value, for two point measurement.</td>
</tr>
<tr>
<td>Derivative</td>
<td>String in front of the Derivative value.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Orientation of the measure label relative to the measurement point: NW - ?, NL- ?, SL-?, SW-?.</td>
</tr>
<tr>
<td>Transparency</td>
<td>Background of the measure label: transparent or opaque.</td>
</tr>
</tbody>
</table>
Figure 5-2  Measure Label Options Dialog
Creating Macros and Expressions

This chapter describes the procedures for building expressions and macros with the Expression Builder in AvanWaves. To analyze simulation data from HSPICE, you can display available raw output data in AvanWaves. However, more complex analyses can be performed by combining the simulation data in mathematical expressions that include

- Predefined functions
- Operators
- Other expressions
- Macros

How these components are combined to create expressions for analysis of simulation data is described in the following sections.
Expression Builder

The **Expression Builder** in Figure 6-1 creates expressions to perform detailed analysis of simulation data. **Results Display** window can display the waveforms that the expressions produce.

**Figure 6-1  Expression Builder Window**

Note: When bringing arguments into expressions, if they contain sweep data, the expression is calculated for each of the sweeps. However, the **Expression Builder** cannot deal with expressions that have different numbers of sweeps for each of its arguments – for example, five sweeps in arg1 and ten sweeps in arg2. The number of sweeps must be the same for all arguments in the expression.

Expressions can be created by typing the expression directly into the expression field, or they can be created by making selections in the desired order from the lists of available functions, waveforms, operators, macros, and other expressions.
Functions

The Functions list shows the functions that are available for use in creating expressions and macros. These are predefined functions. The functions available in AvanWaves are defined in Appendix B.

To use a function in an expression:

1. Select the function from the Functions list, then drag it into the Expression field. Alternatively, double-click on the function to insert it into the Expression field at the current cursor location. You can place the cursor by clicking at the desired insertion location.

2. Enter the arguments for the function either manually or by selecting and dragging curves from the Results Browser.

If a function takes two arguments, you can select both values for these arguments from the Results Browser and drag them to the Expression field together. Each curve entered as an argument is prefixed with its design and analysis number.

All functions work on either constants or waveforms. If a function is applied with one argument that is a constant and one argument that is a waveform, the constant is changed into a “constant value” waveform, and then the operation is performed.

Functions and Expressions can contain arguments that have not yet been defined. A function must have at least one argument, and not more than two. The expression name must be unique.
Operators

A set of arithmetic, numeric comparison, Boolean, and conditional operators are available for use in building expressions and macros in the Expression Builder. The following are the types of operators that you can select from the Operators list:

- Arithmetic (+, -, *, /) — return analog waveforms only
- Comparison (>, <, <=, >=, !=, ==) — return logical waveform results (1 or 0)
- Boolean combination (&&, ||, !) — return logical waveform results (1 or 0)
- Conditional (expr1 ? expr2 : expr3) — analog wave built from expr2 if expr1=0 or expr3 if expr1 is not equal to 0

To use an operator in an expression:

1. Place the cursor in the expression where you want to enter the operator.
2. Select the operator from the Operators list.
3. Click on the operator and drag it into the Expression field.
   Alternatively, double-click on an operator to insert it into the Expression field at the current cursor location.

Using Curves in Expressions

Any curve (simulation waveform) can be placed in an algebraic expression as a parameter. The result of the expression operating on the waveform then can be displayed as a new waveform.
To use a waveform as a parameter in an expression:

1. Select the function to use.
   
   In the Expression Builder window, double-click on the function you want to use in the expression. The function is displayed in the Expression field of the Expression Builder window.

2. Select the waveform.
   
   In the Results Browser, select the waveform you want to use. Holding the mouse button down, drag the waveform into the Expression field of the Expression Builder window. This places the waveform inside the function, so that it can be used as an argument.

Note: A function can have many parameters or arguments. You can select waveforms to be used as parameters in a function one at a time, or make multiple selections. When you insert multiple waveforms in the Expression field, they fill up the parameter values in the order in which you select them.

---

**Selecting and Editing Expressions**

To select an existing expression:

1. Click **Clear**. This clears the Expressions field.

2. With the left mouse button, double-click on the expression (result name) in the Expressions list.

   The actual expression is displayed in the Expression field, and the name of the expression is displayed in the Result field.
To edit the definition of an expression:

1. Select the expression.

2. In the Expression field, modify the expression definition, then click Apply.

   The expression is modified to reflect the changes.

   Another way of modifying an expression is by changing the macro definition within the expression. For more information on Macros, see Editing a Macro.

Using Expressions

The Expressions list contains all the expressions created in AvanWaves using the Expression Builder. The expressions are saved with the current designs when a configuration is created. An expression can be used as part of another expression by selecting it and dragging it into the Expression field.

To add an expression to the Expressions list:

1. Enter an expression in the Expression text entry field, and enter a name for the result in the Result field.

2. Click Apply or press Return to enter the expression in the Expressions list.

   The expression is entered in the list under the Result name.

To expand an expression to display its definition, double-click on the result name in the Expressions list.

   The expression name is entered into the Result field and the expression definition is displayed in the Expression field.
To display an expression:

1. Select the expression name in the Expression list and drag it into the waveform display area of the panel.

   The result of the expression is displayed as a waveform, and the name of the expression, preceded by the design and analysis number, is added to the Wave List in the Results Display window.

   You cannot display an expression whose result is simply a constant, for example, abc = abs(-20). You can use it in another expression, but cannot display a constant result such as ‘abc’ by itself. It must have a signal associated with it.

2. To view the waveforms associated with the expression, double-click on the name of the expression in the Wave List.

   Note: Sweeps that are derived from an expression are not expanded in the Wave List, but they are expanded when they come from the simulator.

Deleting Expressions

To delete an expression from the Expression list, do either of the following:

- Using the left mouse button, select the expression from the list, then click Delete.
- Select the expression, then select Options >> Delete Expression.
Macros are user-defined expressions in a C-like language. The Macros list shows all of the macros created or loaded into AvanWaves. You can select macros from this list, and use them in expressions in the same way that you use functions in expressions. Table 6-1 summarizes the components of a macro.

**Table 6-1  Components of an AvanWaves Macro**

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macro Head</td>
<td>Name of the macro and the names of its arguments.</td>
</tr>
<tr>
<td>Macro Body</td>
<td>Any combination of functions and operators available in the Functions and Operators lists in the Expression Builder window</td>
</tr>
<tr>
<td>Notes</td>
<td>Notes about the macro.</td>
</tr>
</tbody>
</table>

The head of a macro contains the macro name, followed by a parenthesized list of parameters separated by commas. For example the head of a magnitude function can be:

\[ \text{mag}(x, y) \]

The body is the definition of the macro, which uses the parameters specified in the head. For example, the body of a square root function can be:

\[ \text{sqrt}(x^2 + y^2) \]

To use a macro in an expression:

1. Place the cursor in the expression where you want to enter the macro.
2. Select the macro using the left mouse button.
3. Click on the macro with the middle mouse button, and drag and drop it into the expression field.
Alternatively, you can select the macro and double-click on it with the left mouse button.

Creating and Using Macros

To create a macro:

1. Select **Options > Add Macro** in the **Expression Builder**.
   This displays the **Add Macro** dialog box, as shown in **Figure 6-2**.
2. Enter the name of the macro and the arguments associated with the macro into the **Macro Head** field.
3. Enter the macro definition into the **Macro Body** field. The macro definition can contain functions and operators defined previously in the **Expression Builder** window.
4. Click **Apply** to add the macro to the **Macros** list.

**Figure 6-2  Add/Edit Macro Dialog**

![Add/Edit Macro Dialog](image)
To use a function or operator in a macro definition:
1. Place the cursor at the point in the macro where you want to enter the function or operator.
2. Select the function or operator with the left mouse button.
3. Click on the function or operator with the middle mouse button, and drag and drop it into the macro body.

To use an operator in a macro definition:
1. Place the cursor at the point in the macro where you want to enter the operator.
2. Select the operator with the left mouse button.
3. Click on the operator with the middle mouse button, and drag and drop it into the macro body.

---

**Displaying a Macro**

To display a macro that has previously been defined:
1. Select the macro from the **Macros** list.
2. Select **Options > Edit Macro**.
   
   The Macro head, definition, and any notes on the macro in the **Edit Macro** dialog are displayed.

---

**Editing a Macro**

To edit a macro:
1. Click on the macro you want to edit in the **Macros** list.
2. Select **Options > Edit Macro**.
   
   This displays the **Edit Macro** dialog box containing the macro you selected.
3. Enter your changes to the macro head, body, or notes sections.
4. Click **OK** to apply the changes you made.

   The updated **Macro** is added back to the **Macros** list.

To update an expression after editing a macro:

1. In the **Expression Builder**, select each expression that uses the macro.
2. Click **Apply**.

   This updates the expressions to use the new macro definition.

---

**Loading a Macro**

The **Load Macros** function is used to load previously-saved macros into the Macros list. You define the macros, and you can use them in building expressions.

Note: The **Load Macros** dialog by default lists the available macro files with names of the form *.mac. Use the Filter command to display other types of files.
To load a macro:

1. Select the directory location of the macro and select the name of the saved macro file.

2. Click **OK** or **Apply** to load the selected macro file and add it to the Macros list in the **Expression Builder** window.

---

**Saving a Macro**

The **Save Macro** window allows you to save macros created during the current session to a file. This allows you to load and use them in another AvanWaves session with other designs.

To save a macro:

1. In the **Save Macro** dialog, select the directory and the name of the file in which to save the macro.
2. Click **OK** or **Apply** to save the macro definition to the selected file.

---

**Deleting a Macro**

To delete a macro, choose one from the **Macros** list and select:

**Options > Delete Macro**
Using Configurations

A configuration in AvanWaves is a snapshot of the AvanWaves environment. You can create and save a configuration, or a set of configurations, for any design. You can open a saved configuration later in the same AvanWaves session or in future AvanWaves sessions.

The following information is saved in a configuration file:

- status of all tools, windows, measurements, and notes
- all panels and waveform displays
- expressions and macros
- interactive measurement data
- labels
Configuration Files

Configurations are stored in configuration files with names of the form `<config_name>.cfg` in the directory `<design>.sav` in your design directory. Use the Configuration > Save command to name the file in which to save the configuration. You can use the Configuration > Open command to load the configuration back into AvanWaves.

You must open a design (with the Design > Open command) before you can use any of the Configuration menu commands.

Saving a Configuration

To save a configuration, select the Configuration > Save command in the Results Display window.

The Save Configuration dialog appears. The complete path to the current design is shown in the Design field. The Save Configuration dialog allows you to save the configurations during a AvanWaves session. This is helpful for documenting your circuit simulation, or for restoring a configuration in a later AvanWaves session. Only data derived during your present session is stored.

Figure 7-1   Save Configuration Dialog

![Save Configuration Dialog](image-url)
1. In the **Config** field, enter the name of the file in which you want to save the current configuration.

2. Click **Save** to save the configuration.
   
   If a configuration file with the same name already exists in the `<design>.sav` directory, you will be asked to confirm that you want to overwrite it.

3. Click **OK** to overwrite the configuration, or **Cancel** to cancel the current operation.

---

**Opening a Configuration**

To open a saved configuration, select the **Configuration > Open** command in the **Results Display** window.

The **Open Configuration** dialog opens.

*Figure 7-2  Open Configuration Dialog*

![Open Configuration Dialog](image)

The **Design** field shows the complete path to the current design. The **Config** field shows the name of the first configuration that you opened for the current design. Before opening a new configuration, you are prompted to save the state of your current design.

To see a list of all configurations for the current design:

1. Click the left mouse button on the arrow in the **Config** field.

   The pull-down menu displays.
2. Select a configuration from the menu, then click **Open**.

The new configuration opens.

Opening a configuration removes all of the information on the screen about the current design and replaces it with the design information associated with the selected configuration. The state of the panels and the tools is set to the state of the configuration just opened.

If the configuration you opened belongs to the current design, but also contains waveforms from another design, the associated design is opened and displayed. Another window also is opened, listing the waveforms that were not retrieved in opening the configuration, giving the design name, and giving you the option to open the design. To open the design, click **Apply** in this window. The design is then opened and the panels updated with the waveforms.

Note: You can see only the configurations associated with the current design.

---

**Deleting a Configuration**

To delete a configuration:

1. Select the **Configuration > Delete** command in the **Results Display** window.

   This displays the **Delete Configuration** dialog box. The path to the currently open design is listed in the **Design** field.

2. To select the configuration you want to delete, click on the pull-down arrow in the **Config** field.

3. Select the configuration to delete.

4. Click on **Delete**.
This chapter describes how to customize your environment and setting personal preferences in MetaWaves. You can set:

- General application preferences
- Preferences for displaying and analyzing waveforms, such as waveform color and symbol type
Select Preferences Window

Open the Select Preferences window by selecting Tools > Preferences in the Results Display window. The Select Preferences window contains a set of menu options (see Table 8-1) that provide general information on the MetaWaves application. (See Figure 8-1.) Select options on the menu or click on the lists in the dialog box to set your general application preferences.

Figure 8-1  Select Preferences Window

Table 8-1  Select Preferences Menu Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt;&gt; Close Window</td>
<td>Closes the Select Preferences window.</td>
</tr>
<tr>
<td>Edit &gt;&gt; Selected</td>
<td>Not available in this release.</td>
</tr>
<tr>
<td>Edit &gt;&gt; Application &gt;&gt; About</td>
<td>Displays the About box for the MetaWaves application, including version and copyright information.</td>
</tr>
<tr>
<td>Edit &gt;&gt; Application &gt;&gt; General</td>
<td>Displays a dialog box for setting general application preferences for font, foreground, and background colors.</td>
</tr>
<tr>
<td>Edit &gt;&gt; Analysis &gt;&gt; Curves</td>
<td>Sets color preferences and continuity for displaying waveforms, the symbol type, and selects frequency for displaying data points on waveforms.</td>
</tr>
</tbody>
</table>
Setting Analysis Preferences

The Set Analysis Preferences window is used to select the following waveform attributes:

- Color of the displayed waveform
- Whether the continuity symbol is displayed
- Symbol that represents the displayed data points on a waveform
- The frequency with which the symbols are placed on a waveform

This dialog sets the defaults for the eight curve preferences inherited in each panel. The preferences for each curve are set individually.

To bring up the Set Analysis Preferences window, in the Select Preferences window select Edit > Analysis > Curves.

Setting Waveform Color

You can use a default set of colors to initially display curves. You can change the colors in the set, and the order in which you use them.

To customize the color of a waveform:

1. Click in the color box associated with a particular curve.
   
   The Color Preference Chooser is displayed.

2. In the circular color palette, select the color in which you want to display the curve.
   
   The selected color is displayed in a view box beside the palette. Three color control boxes (Light, Hue, and Saturation) are displayed below the palette.

3. Click inside these boxes to select the amounts of light, hue, and saturation that you want to make up the new color.
   
   The arrows move to indicate your new Color, Hue, and Saturation selections.
4. Repeat these steps for each curve for which you want to change the display color.

5. To apply the color to the currently selected curve, click **OK**.

6. The dialog box disappears and the color box in the Set Analysis Preferences window updates.

**Setting Continuity Display**

Select **Continuity** to display connections between data points in a waveform. Set **Continuity** off to display only symbols representing the data points, with no curve segments connecting the symbols. The default value is on. A single click toggles the feature on or off.

**Setting Line Style**

You can assign different line styles to each curve to differentiate waveforms on monochrome hardcopy plots. Default line styles are automatically assigned to the basic set of eight curves.

To change the line style assigned to a curve:

1. Click on the line style that you want to change.

   The appropriate **Line Style Chooser** opens for the particular curve associated with that line style.

2. Select a line style from one of the eight line styles available for each curve.

3. Click **Apply**.

**Setting Symbol Type**

You can assign different symbols to each curve to differentiate waveforms on monochrome hardcopy plots. To select the symbols that represent the data points on a curve, use the **Symbol** function. You can use only one symbol per curve. Default symbols are automatically assigned to the basic set of eight curves.
To change the symbol assigned to a curve:

1. Click on the symbol to change. The appropriate **Symbol Chooser** opens for the particular curve associated with that symbol.

2. Select one of the nine symbols available for each curve.

3. Click **Apply**.

**Setting Symbol Frequency**

The Frequency setting determines how many of the available data points on a waveform are marked with the designated symbol. For example, a symbol frequency of 2 displays the symbol for alternate data point. A frequency of 0 means that only the first data point on the curve is marked with the symbol. Click **OK** to apply the preference selections.

**Setting General Preferences**

The **Set General Preferences** dialog lets you set preferences for foreground and background colors and to set the font used for menu and window names and for displaying messages.

To open the **Set General Preferences** window, in the **Select Preferences** window select **Edit > Application > General**.

**Setting Font**

The **Font Preference Chooser** allows you to customize the font used in the MetaWaves application.
To customize the font:

1. Click **Set Font** to open the **Font Preference Chooser**.
2. In the **Family** box, select the font you want to use.
   The selected font is displayed in a view box at the top of the **Font Preference Chooser** dialog box.
3. In the **Face** box, select the typeface that you want to use.
4. In the **Size** box, select the font size
   The fonts available depend on your current windowing system.
5. Click **OK**.

**Setting Background and Foreground Colors**

Use the **Color Preference Chooser** to customize the foreground and background colors for your application.

To set background or foreground colors in the MetaWaves interface:

1. To open the **Color Preference Chooser**, click **Set Background** or **Set Foreground**.
2. In the circular color palette, select the color you want by clicking on that colored area.
   The selected color is displayed in a view box beside the palette. Three color control boxes (**Light**, **Hue**, and **Saturation**) are displayed below the palette.
3. To select the amounts of light, hue, and saturation that you want to make up a particular color, click inside these boxes.
   The arrows move to indicate your **Color**, **Hue**, and **Saturation** selections.
4. To apply the color to the foreground or background, click **OK**.
   The dialog box disappears and the colors are updated.
Run Manager

The AvanWaves Run Manager provides a way to start and stop HSPICE, edit the source files, and view the listing files for all of the open designs within the session. The status of the simulation run also is echoed to the screen for reference.
Invoking the Run Manager

To invoke the Run Manager from AvanWaves, select

Tools > Run HSPICE

This command opens the Run Manager dialog box, listing all open designs in the Designs listbox and the Status of each, as shown in Figure 9-1. Table 9-1 describes the features of the Run Manager dialog box.

Note: Although this section uses HSPICE as an example, you can easily substitute it with Star-SimXT by changing the value in the Default Simulator field under the Preferences button.

Figure 9-1   Run Manager Dialog
Table 9-1  Features of the Run Manager Dialog

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Lists the present status of each HSPICE job.</td>
</tr>
<tr>
<td>Design</td>
<td>Lists all open designs. You can run a design, edit a source file, and view a listing in simultaneous windows.</td>
</tr>
<tr>
<td>Run</td>
<td>Displays the server chooser dialog for you to run HSPICE.</td>
</tr>
<tr>
<td>Stop</td>
<td>Stops the HSPICE run.</td>
</tr>
<tr>
<td>Source</td>
<td>Displays a window with the editor of your choice to edit the HSPICE source file (.sp file).</td>
</tr>
<tr>
<td>Listing</td>
<td>Displays a window with the editor of your choice to view the HSPICE listing file (.lis file).</td>
</tr>
<tr>
<td>Preferences</td>
<td>Displays the <strong>Run Manager Preferences</strong> dialog, allowing you to select the type of text editor, simulator, and terminal to use.</td>
</tr>
</tbody>
</table>
Running HSPICE

To run HSPICE from the Run Manager:

1. Select a design to run from the Designs listbox.

2. Click on the Run button.

   HSPICE is run on the design that you just selected.

3. Select Panel > Update to update the waveform display with the new simulation data.

Editing the HSPICE Source File

To edit the HSPICE input file (.sp file), click on the Source button in the Run Manager dialog, displayed in Figure 9-2. The source code is shown in the window with the selected text editor.

Figure 9-2  HSPICE Source in VI Editor Window

```
File: mosiv.sp

*mos iv sweep vds to 50v, vbs=0 vgs=.5v,.6v,.7v,.8v,.9v,1v,2v,3v,4v,5v
*
.option nopage nomod post=2
+  neutol relmos=1e-4 absmos=1e-8 relv=1e-4 relvdc=1e-4
.temp 25
.param l=5u w=20u
mvgo5 1 v0.5 0 vb nch l=1 w=w
mvgo6 1 v0.6 0 vb nch l=1 w=w
mvgo7 1 v0.7 0 vb nch l=1 w=w
mvgo8 1 v0.8 0 vb nch l=1 w=w
mvgo9 1 v0.9 0 vb nch l=1 w=w
mv1  1 v1  0 vb nch l=1 w=w
mv2  1 v2  0 vb nch l=1 w=w
mv3  1 v3  0 vb nch l=1 w=w
mv4  1 v4  0 vb nch l=1 w=w
mv5  1 v5  0 vb nch l=1 w=w
vds 1 0
vg0.5 v0.5 0 0.5
vg0.6 v0.6 0 0.6
vg0.7 v0.7 0 0.7
vg0.8 v0.8 0 0.8
```
Viewing the Listing File

After a simulation is completed, you can view the listing file (.lis) by clicking the Listing button in the Run Manager dialog. The listing file is shown in the window with the editor of your choice, as shown in Figure 9-3.

Figure 9-3  HSPICE Listing File in VI Editor Window

```
****** H S P I C E --  95.2 (950213)  09:01:51  95/06/30  sun4
Copyright 1994 (C) by Meta-Software, Inc.
This computer program is protected by copyright law and international treaties. Any dissemination or use of this program, other than that permitted by Meta-Software, Inc., is unlawful and may result in prosecution under the law.
Input File: mosiv.sp
lic: USER: clin HOSTNAME: metaphor HOSTID: 5542cf44
lic: contacting server: enggw
lic: Server permit path: /release/95.2/permit.hsp
lic: Site: meta_software Created: 950222 Order#: 48569
lic: NodeLocked (NL) license for hspice granted
Init: read login configuration file: /work/clin/meta.cfg
******
file: mosiv.sp

******

*mos iv sweep vds to 50v, vbs=0 vgs=.5v,.6v,.7v,.8v,.91v,2v,3v,4v,5v
* .option nopage nomod post=2
+ newtol relmos=1e-4 absmos=1e-8 relv=1e-4 relvdc=1e-4
.temp 25
```
Run Manager Preferences

You can customize the HSPICE run environment, such as setting the default simulator, the editor command, and the X-term command for Run Manager. To open the preference dialog (see Figure 9-4), click on the Preferences button in the Run Manager dialog. Table 9-2 summarizes the fields in the Run Manager Preferences dialog.

Figure 9-4  Run Manager Preferences Dialog

Table 9-2  Run Manager Preferences Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default simulator</td>
<td>Usually HSPICE. Star-SimXT is an alternative.</td>
</tr>
<tr>
<td>Editor command</td>
<td>Common options are vi or emacs. If your editor displays its own window, leave no entry in the XTERM command field.</td>
</tr>
<tr>
<td>XTERM command</td>
<td>Enter xterm in this field.</td>
</tr>
<tr>
<td>Machine</td>
<td>Enter the machine identification in this field.</td>
</tr>
<tr>
<td>Version</td>
<td>Enter the path to the install directory for the simulator that you want to run.</td>
</tr>
</tbody>
</table>
Running the Tutorial

The examples within this chapter describe how you can use AvanWaves to evaluate the results of various types of HSPICE simulations. This chapter contains examples for three kinds of analysis:

- AC
- Transient
- Fast Fourier Transform (FFT)
The example files are included with the product distribution. Working with these examples will demonstrate how to use AvanWaves to:

- Create a Bode plot, using the AC analysis results obtained from HSPICE.
- Review the results of an HSPICE transient simulation with FFT analysis.

Table 10-1 lists example files and locations for each analysis type.

**Table 10-1  Example Files**

<table>
<thead>
<tr>
<th>Analysis</th>
<th>Directory</th>
<th>File Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRANS and FFT</td>
<td>$installdir/demo/awaves/tutorial/tran</td>
<td>cpath.sp</td>
</tr>
<tr>
<td>AC</td>
<td>$installdir/demo/awaves/tutorial/ac</td>
<td>amc1741.sp</td>
</tr>
</tbody>
</table>

**Invoking AvanWaves**

To run AvanWaves, type this command on the command line:

```bash
awaves
```

The **About AvanWaves** window displays on the screen, followed by the **Results Display** window. This is the main application window, which contains all the menu options and tools used in AvanWaves. It also is the main display window for viewing waveforms.

AvanWaves also can be run with a number of options on the command line allowing you to specify the design that you want to use before you enter the application. In this case AvanWaves is loaded with the design and the environment is set up for that particular design. Additional setup information is provided in Chapter 2, “Getting Started”.

Running the Tutorial:

10-2
Transient and FFT Analysis

This example uses AvanWaves to evaluate the results of an HSPICE transient simulation with FFT analysis. This example uses the cpath.sp design, in the $installdir/awaves/tutorial/tran/ directory.

Opening the Design

To open the cpath.sp design:

1. In the Results Display window, select Design > Open.
   The Open Design window appears.

2. In the Open text area, enter the following design file path name:

   $installdir/demo/awaves/tutorial/tran/cpath.sp

3. Click OK.

The Results Browser opens, listing all analysis files associated with this design.

Selecting the Analysis File

The Results Browser displays the different analyses associated with the design. Three analysis files are available:

- A0 — typical model
- A1 — slow model
- A2 — fast model

To display a waveform, you must select an analysis file and an analysis type. You can then display an output waveform associated with that analysis in a panel by selecting it in the Results Browser, as shown in Figure 10-1.
To display a curve:

1. In the **Results Browser**, select the typical model, **A0**.
2. In the **Types** section, select **Voltages** as the analysis type.
   - This displays a list of all the curves associated with that type in the **Curves** area.
3. In the **Curves** section of the **Results Browser**, select the curve **v(q6)**, then drag it into the Panel in the **Results Display** window.
The voltage output displays versus time for five inverter sizes, as shown in Figure 10-2.

Figure 10-2  Results Display Window Showing Sweeps for v(q6)

To select and display the curve v(q6) for analyses A1 and A2:

1. In the Results Browser, select the A1 model. The curves are listed for this analysis.
2. In the Types section, select Voltages as the analysis type.
3. Select the curve v(q6), then drag it into the results display area.

Select the A2 model, and do the same for it using the curve v(q6). One waveform for each analysis is now displayed in the Results Display window, as shown in Figure 10-3.
Sweep Filtering

You can select sweeps for highlighting, displaying, or deleting.

To highlight a specific sweep among a set of sweeps:

1. Double-click on the waveform name associated with that sweep in the Wave List.

   The name expands to show all of the sweeps associated with the waveform.

2. Double-click on the sweep in the Wave List.

   The Results Display area highlights the specific sweep curve.

You can select the sweeps that you want displayed in the panel using the Sweep Filter. To display the S0 sweep for each of the three analyses, do the following:

   • In the context-sensitive menu associated with the waveform display area, select Sweep Filter.

   The Sweep Filter dialog box displays, listing all sweeps for the waveforms, by analysis type. To show and hide sweeps in the panels, make selections in the Sweep Filter.
To display the S0 sweeps on each of the three analyses, with size=1:

1. In the **Sweep Filter**, select all the zeros in the first column of the dialog box, as shown in Figure 10-4.

2. Click **OK** or **Apply**.

   The three S0 sweeps appear in the panel in the **Results Display** window, shown in Figure 10-5.

**Figure 10-4  Sweep Filter with the S0 Sweeps Selected**

![Sweep Filter with the S0 Sweeps Selected](image)

**Figure 10-5  S0 Displayed for Analyses A0, A1, and A2**

![S0 Displayed for Analyses A0, A1, and A2](image)
Zoom In X Feature

To zoom into the area that you want to measure along the X-axis:
1. In the context-sensitive pop-up menu, select **Zoom > Zoom In X**.
2. Select the area on the X-axis from time=15 to time=25.

The panel changes from the full design view to the selected view.

Note: To avoid the measure labels overwriting each other on the screen, it is recommended that you zoom into the area that you want to measure before you select the **Measure** option.

Measures

Use the **Measure** option to calculate the output delay difference between three models. To measure the delay between two points:
1. Select **Measure > PointToPoint** from the main menu.
2. Move the cursor to the first point.
3. Press and hold the left mouse button.
4. Move the cursor to the second point.
5. Release the left mouse button.

Now you can view the required data. You have obtained the differences in delay between the fast model and the typical model, and the differences in delay between the typical model and the slow model.
FFT Analysis

To display the frequency response of one of the elements based upon the FFT analysis, do the following:

1. To add a new panel to the display area, double-click Add Panel in the Panel List.

2. To display the Expression Builder, click the Expression Builder icon on the Accelerator menu, or select Tools > Expressions.

3. In the Expression Builder, double-click on fftMag() in the Functions list to add it to the Expression definition field.

4. In the Results Browser, select the curve v(q6) and drag it to the Expression definition field of the Expression Builder.

5. Assign a name to the new expression – for example, FFT.

6. To add the new expression to the expressions list, select Apply.

7. Select the expression in the Expression list and drag it into the new panel in the Results Display window.
Figure 10-7  Expression Builder Showing the Selected FFT Expression

Both time and frequency domain outputs displayed in the Results Display window for the chosen element, as shown in Figure 10-8.

Figure 10-8  Time and Frequency Response from FFT Simulation

Running the Tutorial: Transient and FFT Analysis
10-10
Changing Display Parameters

Different scaling and viewing options are available in AvanWaves, such as linear, logarithmic, and zooming, as described below.

1. Click in the X-axis area to display its associated pop-up menu.
2. To change the scale of the axis from Linear to Logarithmic, select **Logarithmic**, then click **Apply** or **OK**, as shown in Figure 10-9.

**Figure 10-9 Selecting Logarithmic on the Scaling Dialog**

![Scaling Dialog](image)

The results display scale changes from linear to logarithmic and the view of the waveform in the panel changes.

**Figure 10-10 Frequency Response Waveform Using Logarithmic Scale**

![Waveform](image)

1. To zoom into the high frequency area of the plot, select **Zoom > Zoom In X** from the context-sensitive menu in the panel.
2. Select the range in which to zoom.

**Figure 10-11** shows the zoomed display.
Transient Analysis Summary

This example demonstrated how to evaluate the results of a transient and FFT Analysis using AvanWaves, which involves:

- Select specific sweeps from a group of sweeps and use the **Sweep Filter**.
- Use **.OPTION MEASURE** to measure the delay between waveforms.
- Zoom in on a section of a waveform using the **Zoom In X** option.
- Create expressions to view an element’s FFT frequency response.
- Change the scale of the X-axis.

AC Analysis

The next example shows how to create a Bode plot using the AC analysis results from an HSPICE simulation. This example uses the `amc1741.sp` design, in the `$installdir/awaves/tutorial/ac` directory.

To open the design, `amc1741.sp`, as previously described, select **Design > Open**, and then enter the design path name:

```
$installdir/demo/awaves/tutorial/ac/amc1741.sp
```

The **Results Browser** lists all analysis files for this design.
Displaying Waveforms

This section shows two waveforms from the same analysis, but having a different type. To display two waveforms in the same panel:

1. In the **Results Browser**, select the AC analysis, A1.
2. In the **Types** section, select **Volts dB** for the analysis type.
   
   A list of all curves for that type in the Curves area is displayed.
3. In the Curves section of the **Results Browser**, select the **vdb(out0** curve, then drag it into the Panel in the **Results Display** window.

*Figure 10-12  Results Browser with vdb(out0 Selected*
The first waveform now displays in the panel. Now select the second waveform from the same analysis, but having a different data type:

1. In the **Types** section, select the type **Volts Phase**.
   A list of all curves for that type in the **Curves** area is displayed.
2. In the **Curves** section of the **Results Browser**, select the curve **out0** and drag it into the Panel in the **Results Display** window.

*Figure 10-13  Display of vdb(out0 and out0)*

---

**Changing the Scale of the Display**

To change the scale of the X-axis:

1. Using the right mouse button, click in the horizontal axis area to display the context-sensitive pop-up menu.
2. Select the option **Scale** from this menu.
   A dialog box displays, to change the scale of the axis.
3. Click the Logarithmic button to change the scale from **Linear** to **Logarithmic**, then click **OK**.
Setting the Zoom Factor

To set the zoom factor for viewing a specific section of the waveform:

1. Click in the waveform display area of the panel to display the context-sensitive pop-up menu.

2. Select Set Zoom from the pop-up menu.

   The Set Local Zoom dialog displays, as shown in Figure 10-15.

3. In the Set Local Zoom dialog, set the following values for the variables displayed, by typing them into the text entry area:

   - For Frequency, set Minimum to 1 and Maximum to 10x.

     The scale factors display in the field next to the text entry area. Click on the scale factors required to select it.

     To change the unit from 0 to x, in the pop-up menu, select x(6).

   - For Volts Phase, set the Minimum to -20 and the Maximum to 120.

   - For Volts dB, set the Minimum to -20 and the Maximum to 120.

4. Click OK to apply the changes.
The view in the panel changes to reflect the zoom factor selected, as in Figure 10-16. This is the Bode plot that you specified to display.

When you use Bode plots, you generally want to measure the phase margin, which is the phase at 0 dB gain.
Measuring Unity Gain Frequency and Phase Margin

To measure the frequency at 0 dB gain:

1. Click in the **Results Display** area of the Panel to display the context-sensitive menu.

2. Select **Measure Preference > All Values**.

3. From the main menu of the **Results Display** window, select **Measure > Point**.
   This allows you to identify points in the display area.

4. Place the first marker on the vdB(out0 curve at Volts dB = 0. Note the unity gain frequency (look at the value in the X coordinate box on the **Accelerator** menu bar).

5. Select **Measure > Point** again. This time place a marker on the Volts Phase curve at the same X value (frequency) as the first marker. To ensure that you have the same X coordinate, again check the frequency in the X coordinate box on the **Accelerator** menu bar.

   The Y value for the second marker, the Phase at 0 dB gain, is the value of the phase margin.

---

**Figure 10-17  Bode Plot Displaying Unity Gain and Phase Margin**
Saving the Configuration

To save the configuration, all of the displays and associated parameters, click **Configuration > Save** and enter a name, for example *bode*, for the configuration. The aspects of the present analysis are saved in configuration file *bode.cfg*.

To bring up the same configuration another time, you can open the configuration file *bode.cfg*, after opening the associated design.

AC Analysis Summary

In this example you learned how to create a Bode plot from an AC analysis, which included:

- Changing the scale of the axes.
- Zooming in on a part of the display.
- Using the Point feature and coordinate value boxes to find the phase margin.
- Saving all aspects of the analysis in a configuration.
Accessing Online Help

In AvanWaves you can get online Help on how to:

- Use a function in a particular window or dialog box, by clicking the Help button
- Use a feature, command, or function available in AvanWaves, either by using the Help-DocSet Browser or by using the Topic arrow keys in each Help page.
To access the AvanWaves online Help system, do either of the following:

- Click the **Help** button in a window or dialog box.
  
  The associated Help page displays.

or

- Position the cursor inside the window on which you want help, and press the **F1** key. This displays the Help page for the currently-selected window or dialog box.

Once you are in the Help system, you can move to other topics using the buttons and menu options available. The Help system has two primary dialog boxes that are used to find a desired topic, the Help page and the **Help-DocSet Browser**. These two windows are described in the following sections.
Help Page

A Help page opens when you ask for Help on a particular topic. The Help page contains help for the requested topic, feature, function, procedure, or command description (see Figure 11-1).

Table 11-1 Pop-Up Menu Buttons on Help Pages

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Enables you to open and close Help pages as you need them. You can select the <strong>Table of Contents</strong>, which is a general index to all the topics available in Help.</td>
</tr>
<tr>
<td>Edit</td>
<td>Not implemented for this release.</td>
</tr>
<tr>
<td>Bookmarks</td>
<td>Enables you to put markers in a document in areas of specific interest to you, and keeps a list of these markers so that you can return to a particular topic at a later time.</td>
</tr>
<tr>
<td>History</td>
<td>Lists the five most recent topics and subtopics that you have viewed during the current Help session. You can use this list to go back to a topic and navigate faster between topics of interest.</td>
</tr>
<tr>
<td>Help</td>
<td>Provides information on the Galaxy product that is used to implement the Help system.</td>
</tr>
</tbody>
</table>
Section Menu

The **Section** pop-up menu displays a list of the Help topics associated with the currently selected topic. The list always contains the parent of the topic selected and the selected topic. At the top level, the list contains all entries under the parent topic.

To select a topic from the list, click on the **Section** menu button, then click on the desired topic in the list. The **Help** page displays Help for the selected topic.
**Topic Selection Arrows**

The **Topic** selection arrows are at the bottom of each Help page and dialog box. To step through the Help topics listed on the **Help-DocSet Browser**, click on the arrow in the direction that you want to move on the **Help-DocSet Browser** list. The previous or next topic on the **Help-DocSet Browser** displays in the Help page.

The most convenient way to navigate through Help topics is to use the **Help-DocSet Browser**, since it provides you with a complete list of all the topics and subtopics on which you can get help.

You can access the **Help-DocSet Browser** through the **File** menu in the Help page. Select **File > Table of Contents**, which displays the Help-DocSet Browser. Double-click on a topic in the list to get Help on that topic. See the description of how to use the **Help-DocSet Browser** below.

---

**Bookmarks**

The **Bookmark** menu allows you to mark a topic to be included in the list of bookmarks. These are points of reference in the Help system to which you can return at any time during the current AvanWaves session. You also can clear bookmarks that have been set.

- To insert a Bookmark, select **Bookmarks > Mark Here**.
  
  This adds the currently-displayed topic to the **Bookmarks List**, which is appended onto the **Bookmarks** menu.

- To display a topic marked by a Bookmark, select the **Bookmarks** menu and one of the **Bookmarks** listed in this menu.

  The contents of the Help page update to reflect the selection.
To delete a Bookmark:
1. Select **Bookmarks > Edit**.

   The **Bookmark Editor** displays.
2. Select the bookmark that you want to delete from the list.
3. Select **Edit > Clear**.

   This removes the Bookmark from the list.

To exit from the online Help system, select **File > Close Browser** from the Help page menu.

---

**Help-DocSet Browser**

When you first open the **Help-DocSet Browser**, the entry displayed in the current Help page is highlighted in the **Entries** list (See Figure 11-2). If you open another Help page or select help on another topic, the entry selection in the **Help-DocSet Browser** is updated to reflect the most current selection. Only one **Help-DocSet Browser** can be opened at a time.

Selecting **File > Table of Contents** in another Help page updates the current **Help-DocSet Browser** to reflect the contents of the currently selected Help page.
Using the Entries List to Get Help

You can get help on any topic or subtopic from the Entries list. Use the scroll bar to scroll through the list of available Help topics.

To get help on a new topic or subtopic:
1. Select the entry you want from the Entries list.
2. Double-click on the entry.
   The entry you selected is displayed in the Help page.
Using Search to Get Help

You can search for help on a particular topic by using the **Search** menu, or by entering keywords directly into the **Search** field and then clicking the **Search** button. You can type an entry directly into the Search field and click **Search** to search for it.

To search based on keywords:

1. Select **Search > List Keywords** from the menu to display the Keywords List.
2. Double-click on a keyword in this list to enter it into the search field.
   
   You can enter multiple search criteria by continuing to double-click on keywords in the **Keyword List**. The keywords are automatically entered in succession into the **Search** field.
3. Click **Search** to search for the **Entries** specified.

   If the search is unsuccessful and does not return any topics, clear the **Search** field and press **Return** to display the full list of Help topics.

   If the search is successful, the list of relevant topics are displayed in the **Entries** section of the **Help-DocSet Browser**. Double-click on an entry to display the Help for that entry.
Command Summary

This appendix contains a summary of the commands available in AvanWaves.
## Table A-1  Command Summary (Sheet 1 of 7)

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design → Open...</td>
<td></td>
<td>Opens a dialog box listing paths to designs that can be opened and used in your analysis.</td>
</tr>
<tr>
<td></td>
<td>→ History</td>
<td>Lists the last five designs opened during the current AvanWaves session.</td>
</tr>
<tr>
<td></td>
<td>→ Special → Home</td>
<td>Returns you to your home directory.</td>
</tr>
<tr>
<td></td>
<td>→ Special → Mark</td>
<td>Marks a directory location for the history list.</td>
</tr>
<tr>
<td></td>
<td>→ Special → Unmark</td>
<td>Removes the current directory location from the marked list.</td>
</tr>
<tr>
<td></td>
<td>→ View → by Name</td>
<td>Lists the files by name in alphabetical order.</td>
</tr>
<tr>
<td></td>
<td>→ View → by Date</td>
<td>Lists the files according to the last date they were modified.</td>
</tr>
<tr>
<td></td>
<td>Modified</td>
<td></td>
</tr>
<tr>
<td></td>
<td>→ View → by Date</td>
<td>Lists the files by the date they were created.</td>
</tr>
<tr>
<td></td>
<td>Created</td>
<td></td>
</tr>
<tr>
<td></td>
<td>→ Filter → Input</td>
<td>Displays the input files only.</td>
</tr>
<tr>
<td></td>
<td>→ Filter → Listing</td>
<td>Displays the listing files only.</td>
</tr>
<tr>
<td></td>
<td>→ Filter → Raw Output</td>
<td>Displays raw data files only (HSPICE graph data files).</td>
</tr>
<tr>
<td></td>
<td>→ Filter → Measures</td>
<td>Displays measure data files only.</td>
</tr>
<tr>
<td></td>
<td>→ Filter → All Files</td>
<td>Displays all the files in the current directory.</td>
</tr>
<tr>
<td></td>
<td>→ Filter → Options°</td>
<td>Displays files with a particular input or output suffix.</td>
</tr>
<tr>
<td>Design</td>
<td>→ Close°</td>
<td>Closes the selected design from the list of designs in the Close Design dialog.</td>
</tr>
<tr>
<td></td>
<td>→ Current°</td>
<td>Displays the path to the currently active design (the design that is open in the Results Browser).</td>
</tr>
<tr>
<td></td>
<td>→ Exit</td>
<td>Exits from the current AvanWaves session, saving the display to a configuration, if the option is selected.</td>
</tr>
</tbody>
</table>
Table A-1  Command Summary (Sheet 2 of 7)

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Panels</td>
<td>→ Add</td>
<td>Adds a new panel to the display area and lists it in the Panel List.</td>
</tr>
<tr>
<td></td>
<td>→ Hide</td>
<td>Closes the selected panel.</td>
</tr>
<tr>
<td></td>
<td>→ Delete Panel</td>
<td>Removes the selected panel from the display area and removes the panel name from the Panel List. The <strong>Delete</strong> command works on a selected Panel and also by selecting the panel name in the Panel List.</td>
</tr>
<tr>
<td></td>
<td>→ Delete Curves</td>
<td>Removes the currently selected curve from the panel and the name of the curve and the associated sweeps from the Wave List.</td>
</tr>
<tr>
<td></td>
<td>→ Update</td>
<td>Updates the currently displayed panels with the most recent information from your design files.</td>
</tr>
<tr>
<td></td>
<td>→ Add Label</td>
<td>Displays a Label dialog box for entering the text for a label to place in a panel.</td>
</tr>
<tr>
<td></td>
<td>→ Delete Label</td>
<td>Removes the selected label from the panel.</td>
</tr>
<tr>
<td></td>
<td>→ Stacked/Overlay Mode</td>
<td>Toggles between stacked waveform mode and overlaid waveform model in the selected panel(s).</td>
</tr>
<tr>
<td>Window</td>
<td>→ Full</td>
<td>Displays the full view of the waveforms displayed in a panel.</td>
</tr>
<tr>
<td></td>
<td>→ Zoom In X</td>
<td>Zooms into a selected area of the panel in relation to the X-axis.</td>
</tr>
<tr>
<td></td>
<td>→ Zoom Out X</td>
<td>Zooms out from a selected area of the panel in relation to the X-axis.</td>
</tr>
<tr>
<td></td>
<td>→ Zoom In Y</td>
<td>Zooms into a selected area of the panel in relation to the Y-axis.</td>
</tr>
<tr>
<td></td>
<td>→ Zoom Out Y</td>
<td>Zooms out from a selected area of the panel in relation to the Y-axis.</td>
</tr>
<tr>
<td></td>
<td>→ Zoom In X/Y</td>
<td>Zooms in any direction into a selected area of the panel.</td>
</tr>
<tr>
<td></td>
<td>→ Zoom Out X/Y</td>
<td>Zooms in any direction out of a selected area of the panel.</td>
</tr>
</tbody>
</table>

Command Summary:
A-3
### Table A-1 Command Summary (Sheet 3 of 7)

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Window</td>
<td>→ Last Zoom</td>
<td>Displays the previous zoom selection in the panel.</td>
</tr>
<tr>
<td></td>
<td>→ Set Zoom</td>
<td>Allows you to set scale X and Y values to define the limits of the display window. For the field following the numeric values select units from a range of milli to tera.</td>
</tr>
<tr>
<td></td>
<td>→ Pan X</td>
<td>Moves the waveform view in relation to the X-axis by the amount specified.</td>
</tr>
<tr>
<td></td>
<td>→ Pan Y</td>
<td>Moves the waveform view in relation to the Y-axis by the amount specified.</td>
</tr>
<tr>
<td></td>
<td>→ Pan X/Y</td>
<td>Moves the waveform view in any direction by the amount specified.</td>
</tr>
<tr>
<td>Measure</td>
<td>→ Point</td>
<td>Identifies a selected point on a waveform.</td>
</tr>
<tr>
<td></td>
<td>→ PointToPoint</td>
<td>Measures the distances between two points selected on a waveform (&quot;deltaX&quot; and &quot;deltaY&quot;) and the slope between the two points. The measurements label appears adjacent to the final point.</td>
</tr>
<tr>
<td></td>
<td>→ Delete Measure</td>
<td>Deletes the selected measure from the panel display.</td>
</tr>
<tr>
<td></td>
<td>→ Delete All Measure</td>
<td>Removes all measure values from the panel display.</td>
</tr>
<tr>
<td>Measure → Measure Label Options</td>
<td>Title</td>
<td>Allows a user title to be entered into a field of this window. This title subsequently appears in each measurement label.</td>
</tr>
<tr>
<td>Measure → Measure Label Options</td>
<td>X1</td>
<td>Causes the X-coordinate of the initial point to be displayed for a PointToPoint measurement.</td>
</tr>
<tr>
<td>Measure → Measure Label Options</td>
<td>Y1</td>
<td>Causes the Y-coordinate of the initial point to be displayed for a PointToPoint measurement.</td>
</tr>
<tr>
<td>Measure → Measure Label Options</td>
<td>Current X</td>
<td>Displays the X-value for a Point measurement. This value is shown for the last point of a PointToPoint measurement.</td>
</tr>
<tr>
<td>Measure → Measure Label Options</td>
<td>Current Y</td>
<td>Displays the Y-value for a Point measurement. This value is shown for the last point of a PointToPoint measurement.</td>
</tr>
</tbody>
</table>
### Table A-1 Command Summary (Sheet 4 of 7)

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Measure → Measure Label Options</td>
<td>Delta X</td>
<td>Displays the X-increment for a <strong>PointToPoint</strong> measurement.</td>
</tr>
<tr>
<td></td>
<td>Delta Y</td>
<td>Displays the Y-increment for a <strong>PointToPoint</strong> measurement.</td>
</tr>
<tr>
<td></td>
<td>Slope</td>
<td>Displays slope = delta Y/delta X for a <strong>PointToPoint</strong> measurement.</td>
</tr>
<tr>
<td></td>
<td>Derivative</td>
<td>Displays dy/dx for a single point or for the last point of a <strong>PointToPoint</strong> measurement.</td>
</tr>
<tr>
<td></td>
<td>Hide</td>
<td>Causes subsequent labels to be hidden. They can be displayed later by resetting <strong>Hide</strong>.</td>
</tr>
<tr>
<td></td>
<td>Orientation</td>
<td>Determines where the label window appears with respect to the measure point. Select one of four options: <strong>NW</strong>, <strong>NE</strong>, <strong>SW</strong>, or <strong>SE</strong>.</td>
</tr>
<tr>
<td>Measure → Measure Preferences</td>
<td>Set Snap → Data Point</td>
<td>Allows measurements only between data points on a waveform.</td>
</tr>
<tr>
<td></td>
<td>Set Snap → All Values</td>
<td>Allows measurements on all parts of the waveform.</td>
</tr>
<tr>
<td></td>
<td>Set Lock → All Angle</td>
<td>Measurement operations can be performed at any angle.</td>
</tr>
<tr>
<td></td>
<td>Set Lock → Lock Vertical At first point</td>
<td>Measurement operations can only be performed in the X direction.</td>
</tr>
<tr>
<td></td>
<td>Set Lock → Lock Horizontal At first point</td>
<td>Measurement operations can only be performed in the Y direction.</td>
</tr>
<tr>
<td></td>
<td>Set Lock → Lock Vertical At X Value</td>
<td>Measurement operations can only be performed in the X value specified in the first measure point.</td>
</tr>
<tr>
<td></td>
<td>Set Lock → Lock Horizontal At Y Value</td>
<td>Measurement operations can be performed only in the Y value specified in the first measure point.</td>
</tr>
<tr>
<td></td>
<td>→ Precision</td>
<td>Sets the precision of the value obtained from measure operations.</td>
</tr>
<tr>
<td></td>
<td>→ Anchor Cursor</td>
<td>Drops a pair of anchored cursors.</td>
</tr>
<tr>
<td>Menu</td>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>Measure → Measure Preferences</td>
<td>→ Remove Cursor</td>
<td>Removes the selected pair of anchored cursors.</td>
</tr>
<tr>
<td></td>
<td>→ Anchor cursor</td>
<td>Displays an anchored cursor showing x and y values.</td>
</tr>
<tr>
<td></td>
<td>→ Remove Anchor</td>
<td>Removes the existing anchor.</td>
</tr>
<tr>
<td>Configuration</td>
<td>→ Open⁰</td>
<td>Opens a configuration that you saved.</td>
</tr>
<tr>
<td></td>
<td>→ Save⁰</td>
<td>Saves the current panel and analysis environment as a configuration.</td>
</tr>
<tr>
<td></td>
<td>→ Delete⁰</td>
<td>Removes a selected configuration from the list of saved configurations.</td>
</tr>
<tr>
<td>Tools</td>
<td>→ Results Browser⁰</td>
<td>Displays the Results Browser containing the currently active design analysis files. This is the same as clicking on the Results Browser icon on the accelerator menu.</td>
</tr>
<tr>
<td></td>
<td>→ Expressions</td>
<td>Displays the Expression Builder, which contains the functions and operators to be used in creating expressions and macros in AvanWaves. This is the same as clicking on the Expression Builder icon on the accelerator menu.</td>
</tr>
<tr>
<td>Tools</td>
<td>→ Add Macro⁰</td>
<td>Displays a dialog for creating macros to use in expressions.</td>
</tr>
<tr>
<td>Tools → Expressions → Macro</td>
<td>→ Edit Macro⁰</td>
<td>Displays a dialog allowing you to edit the Macro.</td>
</tr>
<tr>
<td></td>
<td>→ Load Macro⁰</td>
<td>Displays a dialog for loading a saved Macro.</td>
</tr>
<tr>
<td></td>
<td>→ Save Macro⁰</td>
<td>Saves a Macro for future use.</td>
</tr>
<tr>
<td>Tools → Load Macro⁰ → Save Macro⁰</td>
<td>→ History</td>
<td>Last five designs opened in the current AvanWaves session, which you can open.</td>
</tr>
<tr>
<td></td>
<td>→ Special → Home</td>
<td>Returns you to your home directory.</td>
</tr>
<tr>
<td></td>
<td>→ Special → Mark</td>
<td>Marks a directory location for the History list.</td>
</tr>
<tr>
<td></td>
<td>→ Special → Unmark</td>
<td>Removes the current directory location from the marked list.</td>
</tr>
<tr>
<td></td>
<td>→ View → by Name</td>
<td>Lists the files by name in alphabetical order.</td>
</tr>
</tbody>
</table>
Table A-1  Command Summary (Sheet 6 of 7)

<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools → Load Macro° → Save Macro°</td>
<td>View → by Date Modified</td>
<td>Lists files according to the last date they were modified.</td>
</tr>
<tr>
<td>Tools → View → by Date Created</td>
<td></td>
<td>Lists files by the date they were created.</td>
</tr>
<tr>
<td>→ Filter → Macro Definitions</td>
<td></td>
<td>Lists files that contain Macro definitions.</td>
</tr>
<tr>
<td>→ Filter → All Files</td>
<td></td>
<td>Lists all files in the design.</td>
</tr>
<tr>
<td>Tools → Print → Print button</td>
<td>History</td>
<td>Lists the last five designs opened during the current AvanWaves session that can be selected and opened.</td>
</tr>
<tr>
<td>→ Special → Home</td>
<td></td>
<td>Returns you to your home directory.</td>
</tr>
<tr>
<td>→ Special → Mark</td>
<td></td>
<td>Marks a directory location for the History list.</td>
</tr>
<tr>
<td>→ View → by Name</td>
<td></td>
<td>Lists the files by name in alphabetical order.</td>
</tr>
<tr>
<td>→ View → by Date Modified</td>
<td></td>
<td>Lists files according to the last date they were modified.</td>
</tr>
<tr>
<td>→ View → by Date Created</td>
<td></td>
<td>Lists files by the date they were created.</td>
</tr>
<tr>
<td>→ Filter → PostScript</td>
<td></td>
<td>Lists files that are in PostScript format.</td>
</tr>
<tr>
<td>→ Filter → Encapsulated PostScript</td>
<td></td>
<td>Lists all encapsulated PostScript files.</td>
</tr>
<tr>
<td>→ Filter → All Files</td>
<td></td>
<td>List all files.</td>
</tr>
<tr>
<td>Tools → Preferences°</td>
<td></td>
<td>Opens the Select Preferences dialog for setting personal application preferences.</td>
</tr>
<tr>
<td>→ File → Close Window</td>
<td></td>
<td>Closes the Select Preferences window.</td>
</tr>
<tr>
<td>→ Edit → Selected</td>
<td></td>
<td>Displays the Set Analysis Preferences dialog for setting waveform and symbol preferences.</td>
</tr>
<tr>
<td>→ Edit → Application → About</td>
<td></td>
<td>Displays the AvanWaves About box.</td>
</tr>
<tr>
<td>→ Edit → Application → General</td>
<td></td>
<td>Displays the Set General Preferences dialog for setting the foreground and background color and the font used by the application.</td>
</tr>
<tr>
<td>→ Edit → Analysis → Curves</td>
<td></td>
<td>Displays Set Analysis Preferences dialog that controls waveform display attributes.</td>
</tr>
</tbody>
</table>

Command Summary:

A-7
<table>
<thead>
<tr>
<th>Menu</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td></td>
<td>Opens the AvanWaves on-line Help system.</td>
</tr>
<tr>
<td>Set Zoom</td>
<td></td>
<td>Displays the <strong>Set Zoom</strong> dialog for setting the zoom factor for zooming in and out of selected areas in a panel.</td>
</tr>
<tr>
<td>Set Pan</td>
<td></td>
<td>Displays the <strong>Set Pan</strong> dialog for setting values for panning in a panel.</td>
</tr>
<tr>
<td>Set Grid</td>
<td></td>
<td>Displays the <strong>Set Grid</strong> dialog for setting the location of the first vertical grid line, and the spacing between vertical grid lines, in your waveform display.</td>
</tr>
<tr>
<td>Monotonic/Continuous Plot</td>
<td></td>
<td>Selects a monotonic or continuous waveform in the panel.</td>
</tr>
<tr>
<td>Sweep Filter</td>
<td></td>
<td>Displays a dialog box containing the sweeps associated with the waveforms in the selected panel. Sweeps can be selected or deselected for viewing by clicking on them.</td>
</tr>
<tr>
<td>Scale</td>
<td>→ Linear</td>
<td>Selects a linear scale.</td>
</tr>
<tr>
<td></td>
<td>→ Logarithmic</td>
<td>Selects a logarithmic scale.</td>
</tr>
</tbody>
</table>
Operators and Functions

This appendix lists the operators and functions currently available in AvanWaves.
You can use the following operators in expressions in AvanWaves.

### Table B-1 Arithmetic Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
</tr>
</tbody>
</table>

### Table B-2 Comparison Operators (Return 0 or 1 Values)

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;</td>
<td>Greater than</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Greater than or equal to</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Less than or equal to</td>
</tr>
<tr>
<td>!=</td>
<td>Not equal to</td>
</tr>
<tr>
<td>==</td>
<td>Equal</td>
</tr>
</tbody>
</table>

### Table B-3 Boolean Operators (Return 0 or 1 Values)

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function Description</th>
</tr>
</thead>
</table>
| &&       | Performs the **AND** operation.  
  - Returns 1 if both values are nonzero.  
  - Returns 0 otherwise. |
| ||       | Performs the **OR** operation.  
  - Returns 1 if either value is nonzero.  
  - Returns 0 otherwise. |
| !        | Performs the **NOT** operation.  
  - Returns 1 if its argument is 0.  
  - Returns 0 otherwise. |
Table B-4  Conditional Operator

<table>
<thead>
<tr>
<th>Operator</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;expr1&gt;</code> ?</td>
<td><code>&lt;expr2&gt;</code>, and <code>&lt;expr3&gt;</code> are expressions. If the result of <code>&lt;expr1&gt;</code> is nonzero, then</td>
</tr>
<tr>
<td><code>&lt;expr2&gt;</code> :</td>
<td>the result of <code>&lt;expr2&gt;</code> is returned, otherwise the result of <code>&lt;expr3&gt;</code> is returned.</td>
</tr>
<tr>
<td><code>&lt;expr3&gt;</code></td>
<td></td>
</tr>
</tbody>
</table>

Predefined Functions

You can use the functions in Table B-5 in expressions in AvanWaves.

Table B-5  List of Predefined Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>abs(x)</td>
<td>Returns the absolute value of x,</td>
</tr>
<tr>
<td>atan(x)</td>
<td>Returns the arctangent of x (radians).</td>
</tr>
<tr>
<td>atan2(y,x)</td>
<td>Returns the arctangent of y/x between -pi and pi.</td>
</tr>
<tr>
<td>cos(x)</td>
<td>Returns the cosine of x (radians).</td>
</tr>
<tr>
<td>cosh(x)</td>
<td>Returns the hyperbolic cosine of x (radians).</td>
</tr>
<tr>
<td>decibel(x)</td>
<td>Returns the base 10 logarithm of the absolute value of x, multiplied by 20,</td>
</tr>
<tr>
<td></td>
<td>with the sign of x: (sign of x)20log10(</td>
</tr>
<tr>
<td>derivative (curve)</td>
<td>Returns the derivative of the curve.</td>
</tr>
<tr>
<td>exp(x)</td>
<td>Returns e raised to the power x, $e^x$.</td>
</tr>
<tr>
<td>fftImag(curve, start, stop, numpoints, window, alpha)</td>
<td>Returns the imaginary components of a Fast Fourier Transform. Start and stop must be specified as real decimal numbers, for example: 0.0000000.</td>
</tr>
<tr>
<td>fftMag(curve, start, stop, numpoints, window, alpha)</td>
<td>Returns the magnitude of a Fast Fourier Transform:</td>
</tr>
<tr>
<td></td>
<td>fftMag(curve, start, stop, window, alpha) =</td>
</tr>
<tr>
<td></td>
<td>mag((fftReal(curve, start, stop,window, alpha),</td>
</tr>
<tr>
<td></td>
<td>fftImag(curve, start, stop, window, alpha)) start and stop</td>
</tr>
<tr>
<td></td>
<td>must be specified as real decimal numbers.</td>
</tr>
<tr>
<td>fftPhase(curve, start, stop, numpoints, window, alpha)</td>
<td>Returns the phase of a Fast Fourier Transform:</td>
</tr>
<tr>
<td></td>
<td>fftPhase(curve, start, stop,window, alpha) =</td>
</tr>
<tr>
<td></td>
<td>phase((fftReal(curve, start, stop,window, alpha),</td>
</tr>
<tr>
<td></td>
<td>fftImag(curve, start, stop, window, alpha)) start and stop</td>
</tr>
<tr>
<td></td>
<td>must be specified as real decimal numbers.</td>
</tr>
<tr>
<td>fftReal(curve, start, stop, numpoints, window, alpha)</td>
<td>Returns the real components of a Fast Fourier Transform</td>
</tr>
<tr>
<td></td>
<td>Start and stop must be specified as real decimal numbers.</td>
</tr>
<tr>
<td>imag(mag,ph)</td>
<td>Converts polar to rectangular form:</td>
</tr>
<tr>
<td></td>
<td>imag(mag,ph) = mag * sin(ph).</td>
</tr>
</tbody>
</table>
Table B-5  List of Predefined Functions (Continued)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>integer(x)</td>
<td>Returns the integer portion of x (truncates decimal portion).</td>
</tr>
<tr>
<td>integral(curve)</td>
<td>Returns the integral of the curve.</td>
</tr>
<tr>
<td>log(x)</td>
<td>Returns the natural logarithm of the absolute value of x, with the sign of x: (sign of x)log(</td>
</tr>
<tr>
<td>log10(x)</td>
<td>Returns the base 10 logarithm of the absolute value of x, with the sign of x: (sign of x)log_{10}(</td>
</tr>
<tr>
<td>mag(y,x)</td>
<td>Converts from rectangular to polar form: sqrt(y^2 + x^2).</td>
</tr>
<tr>
<td>max(x,y)</td>
<td>Returns the numeric maximum of x and y.</td>
</tr>
<tr>
<td>min(x,y)</td>
<td>Returns the numeric minimum of x and y.</td>
</tr>
<tr>
<td>phase(y,x)</td>
<td>Converts from rectangular to polar form: returns the arctangent of y/x between -180 and 180 (degrees).</td>
</tr>
<tr>
<td>pow(x,y)</td>
<td>Returns x to the power y.</td>
</tr>
<tr>
<td>real(mag,ph)</td>
<td>Converts polar to rectangular form: real(mag,ph) = mag * cos(ph).</td>
</tr>
<tr>
<td>sin(x)</td>
<td>Returns the sine of x (radians).</td>
</tr>
<tr>
<td>sinh(x)</td>
<td>Returns the hyperbolic sine of x (radians).</td>
</tr>
<tr>
<td>sqrt(x)</td>
<td>Returns the square root of the absolute value of x: sqrt(-x) = -sqrt(</td>
</tr>
<tr>
<td>tan(x)</td>
<td>Returns the tangent of x (radians).</td>
</tr>
</tbody>
</table>

FFT Parameters

HSPICE FFT simulation uses double precision floating point numbers, compared with the single precision floating point of the Graph data files in normal simulation.

Table B-6 lists parameters used with FFT functions in AvanWaves.

Note: The AvanWaves equivalent to the HSPICE .FFT simulation is the fftMag function.
In FFT analysis, windows are frequency-weighting functions applied to the time domain data to reduce spectral leakage associated with finite-duration time signals. Windows are smooth functions that peak in the middle frequencies and decrease to zero at the edges. This reduces the effects of discontinuities caused by periodic extension.

Table B-7 lists the common performance parameters for FFT windows available in HSPICE.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>output_var</td>
<td>—</td>
<td>Can be any valid output variable, such as voltage, current, or power</td>
</tr>
<tr>
<td>START</td>
<td>See Description</td>
<td>Specifies the beginning of the output variable waveform to be analyzed. Defaults to the START value in the .TRAN statement, which defaults to zero seconds. Specify this value as a real, decimal number, for example 0.00000001. Invalid specification examples are: 10n, 10ns, 1.0 e^-8.</td>
</tr>
<tr>
<td>STOP</td>
<td>See Description</td>
<td>Specifies the end of the output variable waveform to be analyzed. Defaults to the TSTOP value in the .TRAN statement.</td>
</tr>
<tr>
<td>NP</td>
<td>1024</td>
<td>Specifies the number of points used in the FFT analysis. NP must be a power of 2. If NP is not a power of 2, HSPICE automatically adjusts it to the closest higher number that is a power of 2.</td>
</tr>
</tbody>
</table>
| WINDOW    | RECT    | Specifies the window type to use:  
* RECT=simple rectangular truncation window  
* BART=Bartlett (triangular) window  
* HANN=Hanning window  
* HAMM=Hamming window  
* BLACK=Blackman window  
* HARRIS=Blackman-Harris window  
* GAUSS=Gaussian window  
* KAISER=Kaiser-Bessel window |
| ALFA      | 3.0     | Specifies the parameter used in GAUSS and KAISER windows to control the highest side-lobe level, bandwidth, and so on.  
1.0 <= ALFA <= 20.0 |
Refer to *HSPICE Applications User Guide* for more information about FFT windows and FFT simulations.

**Table B-7 Window Weighting Characteristics in FFT Analysis**

<table>
<thead>
<tr>
<th>Window</th>
<th>Equation</th>
<th>Highest Side-Lobe (dB)</th>
<th>Side-Lobe Roll-Off (dB/octave)</th>
<th>3.0-dB Bandwidth (1.0/T)</th>
<th>Worst Case Process Loss (dB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangular</td>
<td>$W(n)=1, 0 \leq n &lt; NP^\dagger$</td>
<td>-13</td>
<td>-6</td>
<td>0.89</td>
<td>3.92</td>
</tr>
<tr>
<td>Bartlett</td>
<td>$W(n)=2n/(NP-1), 0 \leq n \leq (NP/2)-1$</td>
<td>-27</td>
<td>-12</td>
<td>1.28</td>
<td>3.07</td>
</tr>
<tr>
<td></td>
<td>$W(n)=2-2n/(NP-1), NP/2 \leq n &lt; NP$</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hanning</td>
<td>$W(n)=0.5-0.5\cos(2\pi n/(NP-1)), 0 \leq n &lt; NP$</td>
<td>-32</td>
<td>-18</td>
<td>1.44</td>
<td>3.18</td>
</tr>
<tr>
<td>Hamming</td>
<td>$W(n)=0.54-0.46\cos(2\pi n/(NP-1)), 0 \leq n &lt; NP$</td>
<td>-43</td>
<td>-6</td>
<td>1.30</td>
<td>3.10</td>
</tr>
<tr>
<td>Blackman</td>
<td>$W(n)=0.42323-0.49755\cos(2\pi n/(NP-1)) +0.07922\cos(4\pi n/(NP-1))$, $0 \leq n &lt; NP$</td>
<td>-58</td>
<td>-18</td>
<td>1.68</td>
<td>3.47</td>
</tr>
<tr>
<td>Blackman-Harris</td>
<td>$W(n)=0.35875-0.48829\cos(2\pi n/(NP-1)) +0.14128\cos(4\pi n/(NP-1)) -0.01168\cos(6\pi n/(NP-1))$, $0 \leq n &lt; NP$</td>
<td>-92</td>
<td>-6</td>
<td>1.90</td>
<td>3.85</td>
</tr>
<tr>
<td>Gaussian</td>
<td>$\alpha=2.5$</td>
<td>$W(n)=\exp[-0.5\alpha^2(n-NP/2-1)^2/(NP)^2], 0 \leq n \leq (NP/2)-1$</td>
<td>-42</td>
<td>-6</td>
<td>1.33</td>
</tr>
<tr>
<td></td>
<td>$\alpha=3.0$</td>
<td>$W(n)=\exp[-0.5\alpha^2(n-NP/2)^2/(NP)^2], NP/2 \leq n &lt; NP$</td>
<td>-55</td>
<td>-6</td>
<td>1.55</td>
</tr>
<tr>
<td></td>
<td>$\alpha=3.5$</td>
<td>$W(n)=\exp[-0.5\alpha^2(n-NP/2)^2/(NP)^2], NP/2 \leq n &lt; NP$</td>
<td>-69</td>
<td>-6</td>
<td>1.79</td>
</tr>
</tbody>
</table>
Table B-7  Window Weighting Characteristics in FFT Analysis (Continued)

<table>
<thead>
<tr>
<th>Window</th>
<th>Equation</th>
<th>Highest Side-Lobe (dB)</th>
<th>Side-Lobe Roll-Off (dB/octave)</th>
<th>3.0-dB Bandwidth (1.0/T)</th>
<th>Worst Case Process Loss (dB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kaiser-Bessel α=2.0</td>
<td>$W(n) = I_0(x_2)/I_0(x_1)$</td>
<td>-46</td>
<td>-6</td>
<td>1.43</td>
<td>3.20</td>
</tr>
<tr>
<td>α=2.5</td>
<td>$x_1 = \pi \alpha$</td>
<td>-57</td>
<td>-6</td>
<td>1.57</td>
<td>3.38</td>
</tr>
<tr>
<td>α=3.0</td>
<td>$x_2 = x_1 \times \sqrt{1 - \frac{(2(NP/2) - n^2)}{(NP)^2}}$,</td>
<td>-69</td>
<td>-6</td>
<td>1.71</td>
<td>3.56</td>
</tr>
<tr>
<td>α=3.5</td>
<td>$0 \leq n \leq (NP/2) - 1$</td>
<td>-82</td>
<td>-6</td>
<td>0.89</td>
<td>3.74</td>
</tr>
<tr>
<td></td>
<td>$I_0$ is the zero-order modified Bessel function</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

†NP is the number of points used for the FFT analysis.
Terms and Naming Conventions

This appendix provides the AvanWaves terms (see Table C-1) and naming conventions (see Table C-2).
# Table C-1  Glossary of AvanWaves Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis</td>
<td>The execution of a particular type of simulation — for example, AC, DC, or transient analysis. A number of analysis can be performed on each run.</td>
</tr>
<tr>
<td>Continuous Plot</td>
<td>A graph that has points connected in all directions, both positive and negative.</td>
</tr>
<tr>
<td>Curves</td>
<td>The output waveforms for variables simulated in HSPICE.</td>
</tr>
<tr>
<td>Design</td>
<td>The collective information that describes your circuit, such as the analysis files, the netlist, the graph data files, and so on. AvanWaves provides a graphical representation of your circuit design.</td>
</tr>
<tr>
<td>Graph</td>
<td>The graphical representation of the results derived from a simulation run, also known as a waveform or curve. A graph is displayed inside a panel.</td>
</tr>
<tr>
<td>Graph data file</td>
<td>The HSPICE output data files from either sweeps or measures.</td>
</tr>
<tr>
<td>HSPICE</td>
<td>Avan-Software's circuit simulator</td>
</tr>
<tr>
<td>Monotonic Plot</td>
<td>A graph that has points connected in the X direction only</td>
</tr>
<tr>
<td>Panel</td>
<td>Contains all of the information about an analysis in graphical form. A panel has a title, a wave display area, an X-axis and Y-axis, and a Wave List. The number of panels displayed is limited by the window size.</td>
</tr>
<tr>
<td>Results Browser</td>
<td>The dialog box containing a list of all simulation results available for the current design</td>
</tr>
<tr>
<td>Run files</td>
<td>Files resulting from an HSPICE simulation run.</td>
</tr>
<tr>
<td>Sweep</td>
<td>A set of simulation output data with parametric variation. In HSPICE, known as an “outer loop sweep”.</td>
</tr>
<tr>
<td>Sweep Filter</td>
<td>The filter is used to limit the number of data points displayed in the curves area to those that you specifically require.</td>
</tr>
<tr>
<td>Wave Display area</td>
<td>The area of a panel in which waveforms are displayed.</td>
</tr>
<tr>
<td>Waveform</td>
<td>Plotted data from a simulation.</td>
</tr>
<tr>
<td>Waveform Display</td>
<td>The graphical display area inside a panel.</td>
</tr>
<tr>
<td>Wave List</td>
<td>A list of the currently displayed waveforms.</td>
</tr>
</tbody>
</table>
Table C-2  AvanWaves Naming Conventions

<table>
<thead>
<tr>
<th>Name</th>
<th>Convention</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis</td>
<td>Analyses are represented by Analysis numbers, A0 through An. Each analysis has a unique number that acts as an identifier for that analysis.</td>
</tr>
<tr>
<td>Configuration</td>
<td>Configurations have names assigned by users. They are saved in files of the form <code>&lt;config_name&gt;.cfg</code>.</td>
</tr>
<tr>
<td>Design</td>
<td>Designs are represented by a design number, D0 through Dn. Each design has a unique number that acts as an identifier for that design.</td>
</tr>
<tr>
<td>Expression</td>
<td>Expressions consist of a name and definition that you specify. The definition includes functions, macros and their arguments, and operators.</td>
</tr>
<tr>
<td>Macro</td>
<td>Macros have file names that you assign, in the form <code>&lt;macro_name&gt;.mac</code>. You must define macro parameters when you create the macro.</td>
</tr>
<tr>
<td>Panel</td>
<td>All panels have default names such as Panel1, Panel2, and so on. The number indicates the order in which the panels were opened. You can change panel names.</td>
</tr>
<tr>
<td>Sweep</td>
<td>Sweeps are represented by sweep numbers S0 through Sn. Each sweep has a unique number that acts as an identifier for that sweep.</td>
</tr>
<tr>
<td>Waveforms</td>
<td>Waveform names can be no longer than sixteen characters in length. This covers the HSPICE limit for relative waveform names.</td>
</tr>
</tbody>
</table>
Index

A
A0 through An, analysis label 4-5
AC analysis 10-1, 10-12, 10-18
.ac file 1-4, 3-6
accelerator 4-10
accelerator icon 4-10
add
  label 4-13
algebraic expression 6-4
analysis
  AC 10-1, 10-12, 10-18
  FFT 10-1, 10-3, 10-9
  FFT, window weighting B-6
  label 4-5
  transient 10-1, 10-3
  type, dB 10-13
  type, Volts 10-13
  type, Volts Phase 10-14
analysis preference
  color 4-34
  continuity 4-34
  line style 4-34
  symbol 4-34
  symbol frequency 4-34
Anchor A-5
Anchor Cursor A-5
arithmentic operator 6-4

B
Bode plot 10-2, 10-12, 10-18
Boolean operator 6-4
browser
  hierarchy 4-5
  results 4-4
builder, macro 4-4

C
.cfg extension 1-4
changing views 5-2
chooser
  line style 4-38
  symbol 4-37
close design window 3-7
color 4-34
  background and foreground 8-6
  waveform 4-12, 8-3
command line
  syntax 4-2
conditional operator 6-4
configuration 4-11, 7-1
delete 7-4
file, HSPICE 1-4
open 7-3
save 3-9, 10-18
saving 7-2
context sensitive menu 4-8, 4-13, 4-14
continuity 4-34
continuity, setting display 8-4
current design window 3-8
current X-axis 4-7
curve
  area 4-7
  scroll list 4-7
customizing the environment 8-1

D
data
  sweep 6-2
  types 4-6
data point symbol 8-3
dc analysis, HSPICE 2-3
delete
  configuration 7-4
  label 4-13
delta X 5-12
delta Y 5-12
demo 2-2
<design>
  files 4-5
  See also file
design
  exit 3-9
  file 3-6
  flow 1-3
  menu 3-1
  number 3-8
  opening 10-3
dialog, print 4-24
directory
  run 3-3
display
  continuity, setting 8-4
  parameters 10-11
scale, set 10-14
waveform 2-5
X-axis 4-12
Y-axis 4-12
zoom, set 10-15
display window, results 4-4

E
editing HSPICE source file 9-4
environment
  customizing 8-1
examples 10-1
exit design 3-9
expression
  algebraic 6-4
  creating 4-4, 6-1
  editing 6-5
  field 4-16
  list 4-17
expression builder 4-10, 4-15, 6-1
expression field 4-16
expression list 4-17
function 4-15
function list 4-17
macro 4-15
macro list 4-18
operator 4-15
operator list 4-17
result field 4-17
variable 4-15
expression handler 4-4

F
FFT 10-12
analysis 10-1, 10-3, 10-9
analysis, frequency response 10-9
analysis, window weighting B-6
parameter description B-4
field
expression 4-16
result 4-17
file .ac 1-4, 3-6
ac analysis measurement results 1-4, 3-7
ac analysis results 1-4, 3-6
analysis 2-4 .cfg 1-4
dc analysis measurement results 1-4, 3-6
dc analysis results 1-4, 3-6
design 3-6
extensions submenu 3-5 .lis 3-6, 4-5, 9-3 .ma 1-4, 3-7 .ms 1-4, 3-6 .mt 1-4, 3-6
netlist 1-4, 3-6, 9-3
output listing 3-6, 9-3
output listing, viewing 9-5 .pa0 4-5 .sp 1-4, 3-6, 9-3 .st 3-6
status 3-6 .sw 1-4, 3-6 .tr 1-4, 3-6
transient analysis results 1-4, 3-6
transient measure data 1-4, 3-6
type, filter menu 3-5
filter
menu 3-5
menu, file type 3-5
select 4-8
sweep 4-4, 4-23
font, setting 8-5
frequency
margin, measure 10-17
response, FFT
analysis 10-9
function 4-15, 6-3
list 4-17, 6-3
mathematical B-3
predefined 6-1

G
general preferences 8-5
grid
set 4-30
GridSpace 4-30
GridStart 4-30

H
handler, expression 4-4
help, on line 11-1
bookmark 11-5
entries list 11-7
keyword 11-8
search 11-8
table of contents 11-5
hidden panel 2-6, 4-12
hierarchy
browser 4-5
subcircuit 4-5
history menu 3-3
hotkeys 4-39
HSPICE 9-2
dc analysis 2-3
editing source file 9-4
input netlist 1-4, 3-6, 9-3

I
icon, accelerator 4-10
identifier, waveform 4-12

K
keyboard shortcuts 4-39

L
label, analysis 4-5
line style 4-34, 8-4
line style chooser 4-38
linear 10-11
.lis file 3-6, 9-3
list
  expression 4-17
  function 4-17
  macro 4-18
  operator 4-17
  scroll 4-5
  wave 4-8
listing file 3-6, 9-3
logarithmic 10-11

M
.mac file 1-4, 3-7
macro 4-15, 6-8
  builder 4-4
  creating 4-4, 6-1
  displaying 6-10
  list 4-18
  loading 6-12
  menu 4-18
manager, window 2-2
measure 10-12
  label options 5-12
  margin, frequency 10-17
  margin, phase 10-17
  menu 5-8
  options 5-10
  point 4-10, 5-8
  point to point 4-10, 5-8
  preference 4-15
  preference, snap mode 5-10
menu
  bar 4-8, 4-9
  configuration 4-10
  context sensitive 4-8, 4-11, 4-13, 4-14
  design 3-1, 4-9
  filter 3-5
  help 4-10
  history 3-3

M
.mac file 1-4, 3-7
macro 4-18
  measure 4-10, 5-8
  measure, preference 4-15
  panel 4-9
  pop up 4-11
  special 3-4
  tool 4-10, 4-12
  tool, preference 4-12
  window 4-9, 4-15
    set zoom 4-15
    window, preference 5-10
Motif 2-2
.ms file 1-4, 3-6
.mt file 1-4, 3-6
multi select 4-6

N
navigate 3-3
number, design 3-8
numeric comparison operator 6-4

O
on line help 11-1
one point measure 4-10
open
  configuration 7-3
  design 3-2, 10-3
operations, global 5-2
operator 4-15, 6-1
  arithmetic 6-4
  Boolean 6-4, B-2
  comparison B-2
  conditional 6-4, B-3
  numeric comparison 6-4
operator list 4-17
option
  measure 5-10, 10-12
  scale 10-11
  scale, linear 10-11
scale, logarithmic 10-11
scale, zoom 10-11
view 3-4, 10-11
view, linear 10-11
view, logarithmic 10-11
view, zoom 10-11
output listing file 3-6, 9-3

P
pan X 5-6
pan Y 5-6
panel 4-11
  add label 4-13
  configuration 4-11
  context sensitive pop-up 4-11
delete label 4-13
deleting 4-11
hidden 2-6, 4-12
name 4-11
name changing 4-11
print 4-24
results display 4-8
wave list 4-13
waveform 4-11
waveform display 4-11
X-axis 4-11
Y-axis 4-11
performing measurements 5-8
personal preference 8-1
phase margin 10-18
phase margin, measure 10-17
predefined function 6-1, B-3
preference
  analysis 4-34
  analysis, setting 8-3
  application 4-4
  attribute 4-4
  color 4-32, 4-33
  continuity 4-32
data point 4-32
  font 4-33
general 8-5
measure 4-15, 5-10
  option 4-12
  personal 8-1
  run manager 9-3, 9-6
  symbol type 4-32
print 4-4
  dialog 4-24
  manager 4-10
to file 4-25
to printer 4-25

R
range select 4-6
Remove Cursor A-6
result
  ac analysis 1-4, 3-6
  ac analysis measurement 1-4, 3-7
  dc analysis 1-4, 3-6
  dc analysis measurement 1-4, 3-6
  field 4-17
  transient analysis 1-4, 3-6
  transient measure data 1-4, 3-6
results browser 4-4, 4-10
results display window 2-4, 4-4
run
  directory 3-3
  file, HSPICE 1-4
  HSPICE 9-4
  manager 9-1
  manager, preferences 9-3, 9-6
run HSPICE 9-4

S
.sav directory 1-4
save configuration 3-9, 10-18
scale
  display, set 10-14
  linear 4-14
  logarithmic 4-14
  X-axis 4-12
  Y-axis 4-12
scroll list 4-5
select
    filter 4-8
    multi 4-6
    range 4-6
set
    analysis preferences 8-3
    background color 8-6
    display
        continuity 8-4
        display scale 10-14
        display zoom 10-15
    font 8-5
    foreground color 8-6
    general preferences 8-5
    grid 4-30
    line style 8-4
    symbol frequency 8-5
    symbol type 8-4
set zoom 4-15, 4-27
shortcuts, keyboard 4-39
   .sp file 1-4, 3-6, 9-3
   special menu 3-4
   speed bar 4-8, 4-10
   .st file 3-6
   Stacked/Overlay Mode A-3
   status file 3-6
subcircuit
    hierarchy 4-5
   .sw file 1-4, 3-6
sweep 10-12
   data 6-2
   filter 4-4, 4-15, 4-23, 10-6
sweeps 10-6
symbol 4-34
   data point 8-3
   frequency 8-5
   type 8-4
symbol chooser 4-37
syntax, command line 4-2

T
tool
   description 4-4
   menu 4-12
   preferences 8-2
   run HSPICE 9-2
   .tr file 1-4, 3-6
   transient 10-12
   transient analysis 10-1, 10-3
two point measure 4-10
type
   analysis, dB 10-13
   analysis, Volts 10-13
   analysis, Volts Phase 10-14
   list 4-6
U
   using measures 10-8
V
   variable 4-15
   view option 3-4
   viewing output listing file 9-5
   views, changing 5-2
W
   wave list 4-8, 4-13
   waveform 4-11
   color 4-12, 8-3
   display 2-5
   display area 4-11
   identifier 4-12
   window
      close design 3-7
      current design 3-8
      global operations 5-2
      manager 2-2
      menu 5-2
open design 3-2
set zoom 4-27

X
X-axis 4-12, 4-14
  current 4-7
  default 4-7
  display 4-12
  scale 4-12
X-Y coordinate display 4-10

Y
Y-axis 4-12, 4-14
  display 4-12
  scale 4-12

Z
zoom 10-11
  display, set 10-15
  in 4-10, 5-2
  out 4-10, 5-3
  set 4-15, 4-27